Issue 120627 - the text on the Y axis is reversed when export ppt file to PDF format
the text on the Y axis is reversed when export ppt file to PDF format
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: printing
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: WangZhe
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 02:55 UTC by Tang Meng
Modified: 2013-07-12 14:21 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (54.50 KB, application/octet-stream)
2012-08-21 02:55 UTC, Tang Meng
no flags Details
patch (915 bytes, patch)
2012-08-23 07:31 UTC, Tang Meng
no flags Details | Diff
old test result (30.26 KB, application/pdf)
2012-08-23 08:17 UTC, Tang Meng
no flags Details
new test result (30.26 KB, application/pdf)
2012-08-23 08:18 UTC, Tang Meng
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Tang Meng 2012-08-21 02:55:42 UTC
Created attachment 79014 [details]
sample file

Open the sample ppt file, select menu Export as PDF, the text on the Y axis is reversed.
Comment 1 Tang Meng 2012-08-21 02:56:22 UTC
I am looking at this bug.
Comment 2 Li Feng Wang 2012-08-21 03:11:30 UTC
Can reproduce on Windows with AOo trunk r1374181
Comment 3 Tang Meng 2012-08-23 07:31:05 UTC
Created attachment 79088 [details]
patch

patch
Comment 4 Tang Meng 2012-08-23 07:32:33 UTC
1. Root Cause:
The distance calculation between two points in PDFWriterImpl::drawVerticalGlyphs is incorrect. 
The various nXOffset value should be the distance between the last character's position point and the next character's position point. The original value is the distance of axis Y between two points which will make the characters' offset incorrect after aDeltaPos transformed and translated by the matrix.
2. Resolution:
Change nXOffset value from the distance of axis Y between two points to the distance between two points.
Comment 5 Tang Meng 2012-08-23 08:17:36 UTC
Created attachment 79091 [details]
old test result

old test result.
Comment 6 Tang Meng 2012-08-23 08:18:15 UTC
Created attachment 79092 [details]
new test result

new test result.
Comment 7 WangZhe 2012-09-07 04:42:52 UTC
I'll take this one
Comment 8 WangZhe 2012-09-07 05:34:27 UTC
Deliver At revision: 1381883
Comment 9 louqle 2012-11-08 01:32:01 UTC
verified on win7, Mac 10.7 and suse 11 sp1 agaisnt build 1404513, fixed