Issue 120573 - [From Symphony]Page number in footer alignment changed after saved
[From Symphony]Page number in footer alignment changed after saved
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: save-export
3.4.0
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
: ms_interoperability
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 01:23 UTC by Yan Ji
Modified: 2012-12-26 08:36 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (111.00 KB, application/msword)
2012-08-15 01:23 UTC, Yan Ji
no flags Details
patch for the issue (602 bytes, patch)
2012-08-16 01:59 UTC, Lei Debin
debin.lei: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-08-15 01:23:31 UTC
Created attachment 78942 [details]
sample

Build: AOO 3.4.1 rev 1372282
OS: All
Steps:
1. Open attached sample file
2. Page number in footer is align to right
3. Save sample to another doc file
4. Reload saved doc file

Defect: Page number alignment changed to left
Comment 1 Lei Debin 2012-08-15 01:44:38 UTC
I am working on it
Comment 2 Lei Debin 2012-08-16 01:49:42 UTC
Find the root cause.
This is a sw text frame export position info error. 
The page number is a text frame in the page footer. The page Margins is set as "Mirrored" and the text frame's horizontal is "Outside". 

Indirecty fix this type frame position at function "WinwordAnchoring::ConvertPosition", 
don't convert horizontal info and fix the text::HoriOrietation::RIGHT to OUTSIDE.
Comment 3 Lei Debin 2012-08-16 01:57:33 UTC
The fix just impact the doc export and the margin is mirrored and the horizontal info is text::HoriOrietation::RIGHT.
Comment 4 Lei Debin 2012-08-16 01:59:55 UTC
Created attachment 78968 [details]
patch for the issue
Comment 5 zjchen 2012-08-20 01:22:10 UTC
I am volunteering to review this patch.

patch looks good and solves the problem. It is OK for me
Comment 6 SVN Robot 2012-08-20 01:26:45 UTC
"leidb" committed SVN revision 1374892 into trunk:
#120573# fix the export issue for the text box in header&footer with the marg...
Comment 7 Lei Debin 2012-08-20 01:28:02 UTC
thx for zuo jun's review.
Comment 8 Du Jing 2012-08-28 01:59:31 UTC
verified on the build 1377620