Issue 120564 - testuno: testscripts for ParagraphDistanceinShape Function in presentation
testuno: testscripts for ParagraphDistanceinShape Function in presentation
Status: CLOSED FIXED
Product: QA
Classification: Unclassified
Component: testscripts
OOo 3.4 Beta
All All
: P3 normal
: 4.0.0
Assigned To: liuping
:
: 120563 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 05:54 UTC by liuping
Modified: 2013-07-11 12:04 UTC (History)
3 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
BorderProperty.patch (3.68 KB, text/plain)
2012-08-15 08:17 UTC, liuping
no flags Details
ParagraphProperty (5.46 KB, patch)
2012-08-15 08:46 UTC, liuping
no flags Details | Diff
ParagraphTextProperty.patch (6.83 KB, patch)
2012-08-17 02:37 UTC, liuping
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2012-08-14 05:54:41 UTC
Create a path for ParagraphPropertyShape Color Testcase Automation 
1.Create Shape through xComponent(int x, int y,int width, int height, String sShapeType)
2.Set Assert for Shape Setting
3.Create XTextRange through addPortion(XShape xShape, String sText, boolean bNewParagraph)
4.Set Assert for paragraph's color in Shape
Comment 1 liuping 2012-08-15 08:17:18 UTC
Created attachment 78950 [details]
BorderProperty.patch
Comment 2 liuping 2012-08-15 08:44:21 UTC
*** Issue 120563 has been marked as a duplicate of this issue. ***
Comment 3 liuping 2012-08-15 08:46:19 UTC
Created attachment 78956 [details]
ParagraphProperty
Comment 4 liuping 2012-08-17 02:37:47 UTC
Created attachment 78978 [details]
ParagraphTextProperty.patch

save and reopen ,assert statement
Comment 5 liuping 2012-08-17 02:52:31 UTC
(In reply to comment #0)
> Create a path for ParagraphPropertyShape Color Testcase Automation 
1.Create
> Shape through xComponent(int x, int y,int width, int height, String
> sShapeType)
2.Set Assert for Shape Setting
3.Create XTextRange through
> addPortion(XShape xShape, String sText, boolean bNewParagraph)
4.Set Assert
> for paragraph's Distance in Shape
TextLeftDistance/TextRightDistance/TextUpperDistance/TextLowerDistance
Comment 6 SVN Robot 2012-08-17 06:10:21 UTC
"liuzhe" committed SVN revision 1374146 into trunk:
#120564# - UNO patch: Testcase Automation for ParagraphDistanceinShape Functi...
Comment 7 Yan Ji 2012-08-19 03:34:24 UTC
This script has been comitted.