Issue 120554 - [From Symphony]Shape Gradient MS2003 import/export Enhancement
[From Symphony]Shape Gradient MS2003 import/export Enhancement
Status: CLOSED FIXED
Product: Draw
Classification: Application
Component: open-import
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
: 115720 119498 119973 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 09:44 UTC by Jianyuan Li
Modified: 2012-10-10 06:56 UTC (History)
7 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Patch for this issue (26.25 KB, patch)
2012-08-14 06:56 UTC, Jianyuan Li
lijianyuan1983: review?
Details | Diff
UT files for this issue (172.53 KB, application/x-zip-compressed)
2012-08-14 06:57 UTC, Jianyuan Li
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Jianyuan Li 2012-08-13 09:44:05 UTC
About details for this enhancement, please refer to:
http://wiki.services.openoffice.org/wiki/Impress/Features/ShapeGradientEnhancementForMS2003Filter
Comment 1 Li Feng Wang 2012-08-13 09:57:15 UTC
*** Issue 119973 has been marked as a duplicate of this issue. ***
Comment 2 Li Feng Wang 2012-08-13 09:59:51 UTC
*** Issue 119498 has been marked as a duplicate of this issue. ***
Comment 3 Li Feng Wang 2012-08-13 10:01:47 UTC
*** Issue 115720 has been marked as a duplicate of this issue. ***
Comment 4 Jianyuan Li 2012-08-14 06:56:57 UTC
Created attachment 78931 [details]
Patch for this issue
Comment 5 Jianyuan Li 2012-08-14 06:57:48 UTC
Created attachment 78932 [details]
UT files for this issue
Comment 6 Armin Le Grand 2012-08-14 09:18:03 UTC
Hi Jianyuan Li,
please note that the AOO gradient style 'square' has an error currently (see #120539#) which I will fix. It was broken with OOo3.3. 'square' has to work the same as 'radial': It should show quadrats, not rectangles, the same as 'radial' shows circles, not ellipses.
Comment 7 Jianyuan Li 2012-08-14 09:37:14 UTC
Thanks for notes, Armin.
Comment 8 SunYing 2012-08-14 09:38:05 UTC
The var mbRotateGranientFillWithAngle is a sal_bool type, and initialize use sal_false not "0",^_^
Comment 9 Jianyuan Li 2012-08-14 09:49:48 UTC
I will correct this on commit. Thanks
Comment 10 Lei Debin 2012-08-15 05:34:25 UTC
confirmed
Comment 11 SVN Robot 2012-08-16 02:13:27 UTC
"lijiany" committed SVN revision 1373695 into trunk:
#120554# Shape Gradient MS2003 import/export EnhancementReported by: Jianyuan...
Comment 12 Jianyuan Li 2012-08-16 02:46:10 UTC
This is an enhancement. For more details, please refer to:
http://wiki.services.openoffice.org/wiki/Impress/Features/ShapeGradientEnhancementForMS2003Filter
Comment 13 Shenfeng Liu 2012-10-10 06:56:11 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.