Issue 120513 - Writer crashes in word-completion-mode on Insert>Comment
Writer crashes in word-completion-mode on Insert>Comment
Status: VERIFIED FIXED
Product: Writer
Classification: Application
Component: editing
3.4.0
All All
: P3 critical (vote)
: 4.0.0
Assigned To: Armin Le Grand
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 08:51 UTC by richardjk
Modified: 2013-07-09 06:06 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---
jsc: 4.0.0_release_blocker+


Attachments
Crash report generated on close down by OOo 3.0.4 (44.02 KB, text/rtf)
2012-08-09 08:51 UTC, richardjk
no flags Details
stack of the root cause (3.73 KB, text/plain)
2013-06-28 13:10 UTC, hdu@apache.org
no flags Details
updated stack of the root cause (1.84 KB, text/plain)
2013-07-01 11:31 UTC, hdu@apache.org
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description richardjk 2012-08-09 08:51:27 UTC
Created attachment 78893 [details]
Crash report generated on close down by OOo 3.0.4

Writer crashes when I edit a file (doc-extension). Open file, select Edit>Changes>Record, block text segment, delete blocked text segment (result: text segment turns red + strike-through), insert new text segment (result: new text segment red without strike-through), select Insert>Comment (by pressing Option+Cmd+C) to add reason for edit (result: Writer crashes).

Mac OS X 10.6.8
AOO340m1 (build 9590) Rev 1327774 (2012-04-19)
Comment 1 richardjk 2012-08-09 08:58:33 UTC
When I insert new text Writer suggests Word completion. If I hit Option+Cmd+C for Comment with the word completion suggestion still "on", Writer crashes. When I first reject suggested Word completion before hitting Option+Cmd+C Writer does nót crash.
Comment 2 Oliver-Rainer Wittmann 2012-08-10 10:05:34 UTC
I was not able to reproduce the described defect under Windows 7 with AOO 3.4. Following are the steps which I performed:
- open attached document
- Menu - Edit - Changes - Record
- select 3rd, 4th and 5th paragraph and delete these
--> paragraph are marked as deleted now
- right after the deleted paragraphs I inserted a new paragraph and started typing
- when word completion becomes active I hit Ctrl-Alt-C to insert a comment
--> word completion deactivated; comment inserted; cursor placed in comment; no crash
Comment 3 richardjk 2012-08-10 11:56:37 UTC
I just retried, but with the same result as before: with a suggestion from word completion "on" I hit Option+Cmd+C and Writer crashes. The obvious difference between you and me off course being my OS (Mac instead of Windows).

Retried without having selected Edit>Change>Record – normal writing mode, so to say – and the same thing happens. When I insert a comment with Option+Cmd+C with a suggestion from Word completion "on", Writer crashes. If I select Insert>Comment from the menu bar instead of hitting the keyboard combination, Writer also crashes.

Also, when I select Show as tip in Tools>AutoCorrect Options…>tab Word Completion Writer doesn't crash when I insert a comment with a suggestion from Word completion shown as tip "on".
Comment 4 jsc 2012-08-13 08:04:00 UTC
I can reproduce the issue on MacOS. It seems to be already in OOo3.3 where I was able to reproduce it as well. We have to take a closer look on it. But the workaround is very easy and the situation where it happens is probably rather seldom. And it seems to be MacOS only.
Comment 5 Rob Weir 2013-01-09 22:04:13 UTC
Confirmed per jsc
Comment 6 jsc 2013-06-24 12:14:05 UTC
set showstopper flag
Comment 7 hdu@apache.org 2013-06-28 13:10:21 UTC
Created attachment 80943 [details]
stack of the root cause

The pPostIt->GrabFocus() call in PostItMgr.cxx's SwPostItMgr::LayoutPostIts() method causes the pPostIt window to be deleted by the chain of commands triggered by QuickHelpText losing its focus. Subsequent accesses to the dead pPostIt window are bound to cause trouble regardless of the platform.
Comment 8 Armin Le Grand 2013-07-01 10:12:44 UTC
ALG: COuld someone please add a description what has to be activated? I am not able to get that crash, possibly because I do not know where to get 'word completion' and did not find it up to now. Thanks!
Comment 9 Armin Le Grand 2013-07-01 11:13:43 UTC
ALG: Taking a look...
Comment 10 hdu@apache.org 2013-07-01 11:31:16 UTC
Created attachment 80966 [details]
updated stack of the root cause

The word completion list is filled automatically by the text existing in the document. By default it is enabled by only for words >= 10 chars. This limit is configurable in Tools->AutoCorrectOptions->WordCompletion This dialog also shows the list of words-to-be-completed.

A simple example is to
- create an empty document
- enable change tracking (Edit->Changes->Record)
- use the dummy text ("dt" and F3)
=> the words "disappeared", "greenbacks", "noticeable", "particular", "warehouses" in the dummy text are long enough so they will be picked up
- start to type one of these words
- when word-completion becomes active the rest of the word is shown
- now type the keyboard shortcut for Insert->Comment
=> crash caused by the access to the dead window (see the stack)
Comment 11 SVN Robot 2013-07-02 11:30:07 UTC
"alg" committed SVN revision 1498881 into trunk:
i120513 Remove autocompletion suggestion when inserting comment via menu/shor...
Comment 12 Oliver-Rainer Wittmann 2013-07-02 11:34:17 UTC
fixed together with Armin on trunk for AOO 4.0
Comment 13 hdu@apache.org 2013-07-03 08:05:44 UTC
Updated the summary line as the crash happened independent of whether change-recording was enabled. The word-completion mode was what was critical for the shortcut triggered insert-comment action.
Comment 14 fanyuzhen 2013-07-05 06:09:06 UTC
The crash also happens on Windows with revision 1489073.
The latest build I get is AOO 4.0 r1496831, wait for revision 1498881 for verification
Comment 15 fanyuzhen 2013-07-09 06:06:54 UTC
It's verified fixed in revision 1499347