Issue 120224 - [From Symphony]Cell text direction changed after saved as doc file
[From Symphony]Cell text direction changed after saved as doc file
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: save-export
3.4.0
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
: 119483 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 08:57 UTC by Yan Ji
Modified: 2012-12-26 08:22 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (26.50 KB, application/msword)
2012-07-09 08:57 UTC, Yan Ji
no flags Details
proposed patch for Bug 120224 (1.84 KB, patch)
2012-07-10 14:41 UTC, zjchen
zjchencdl: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-07-09 08:57:13 UTC
Created attachment 78599 [details]
sample

Build: AOO 3.4

Steps:
1. Load sample file
2. Save it as another .doc file
3. Reload saved file

Defect: Cell text direction changed
Comment 1 zjchen 2012-07-10 07:30:02 UTC
The problem is table cell text direction feature difference between Writer and MS Word. Writer is able to rotate the text in table cell 90 degrees or 270 degrees via Character Position pane.  While MS WORD doesn't have the text rotation but five text directions in table cell.
The resolution is that mapping the text rotation in Writer table cell into text direction in MS word when save the document as doc file.
Comment 2 zjchen 2012-07-10 14:41:08 UTC
Created attachment 78616 [details]
proposed patch for Bug 120224
Comment 3 SVN Robot 2012-07-19 02:26:26 UTC
"leidb" committed SVN revision 1363208 into trunk:
#120224# Mapping the text rotation in Writer table cell with MSOReported by: ...
Comment 4 Lei Debin 2012-07-19 02:28:24 UTC
Good job, Zuo Jun, Thx.
Comment 5 Du Jing 2012-08-20 09:59:11 UTC
verified on the AOO3.5_r1374181
Comment 6 Lei Debin 2012-08-28 01:25:09 UTC
*** Issue 119483 has been marked as a duplicate of this issue. ***