Issue 120168 - [From Symphony] optimize chart saving to improve xls saving performance
[From Symphony] optimize chart saving to improve xls saving performance
Status: RESOLVED FIXED
Product: performance
Classification: Code
Component: www
AOO 3.4.0
All All
: P3 normal (vote)
: AOO 4.0
Assigned To: Andre
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 08:48 UTC by lizh.fee
Modified: 2013-02-16 09:25 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
patch (1.79 KB, patch)
2012-07-09 06:36 UTC, lizh.fee
awf.aoo: review+
Details | Diff
sample (108.00 KB, application/vnd.ms-excel)
2012-07-09 06:41 UTC, lizh.fee
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lizh.fee 2012-07-03 08:48:50 UTC
xls document with many oles(the chart) in it will cost much time when saving.
Comment 1 lizh.fee 2012-07-03 08:50:49 UTC
Root cause:
All chart will be persisted as xml format on disk when xls saving, which is time consuming.

Resolution:
If the chart has not been modified, then no need to update the persist files redundantly.
Comment 2 lizh.fee 2012-07-09 06:36:30 UTC
Created attachment 78597 [details]
patch
Comment 3 lizh.fee 2012-07-09 06:41:16 UTC
Created attachment 78598 [details]
sample
Comment 4 ChaoHuang 2012-07-09 07:59:26 UTC
(In reply to comment #1)
> Root cause:
> All chart will be persisted as xml format on disk when xls saving, which is
> time consuming.
> 
> Resolution:
> If the chart has not been modified, then no need to update the persist files
> redundantly.

It should be better that if you can add the description of how to do UT for this feature.
Comment 5 lizh.fee 2012-07-09 08:15:08 UTC
steps for UT:

1. functiaonality aspect
open some .xls format document(with ole in it), modify the ole, then save, to see whether the content is right or not.

open some .xls format document(with ole in it), modify some texts, then save, to see whether the content is right or not.

2. performance aspect
open .xls document with many oles in it, do not modify ole or modify small quantities of oles, then save, to see how much time cost by saving compared with old version.
Comment 6 SVN Robot 2012-07-09 15:39:47 UTC
"af" committed SVN revision 1359225: "#i120168# Do not call storeOwn() when not necessary. "
Comment 7 Andre 2012-07-09 15:40:27 UTC
Comment on attachment 78598 [details]
sample

Not a patch, no review necessary.
Comment 8 Andre 2012-07-09 15:40:48 UTC
Comment on attachment 78597 [details]
patch

Reviewed and tested: OK
Comment 9 Andre 2012-07-09 15:42:13 UTC
Setting status to fixed.
Comment 10 ChaoHuang 2012-10-17 08:19:17 UTC
Suggest to put it into AOO 3.5.0 release