Issue 120155 - Help - Support displays blank help page
Help - Support displays blank help page
Status: VERIFIED FIXED
Product: General
Classification: Code
Component: code
3.4.0
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Ariel Constenla-Haile
:
: 121807 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 23:57 UTC by Ariel Constenla-Haile
Modified: 2013-02-21 10:45 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: 3.4.1
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Ariel Constenla-Haile 2012-07-02 23:57:22 UTC
Select menu "Help" - "Support".
The Help opens with a blank page.
It should display main/helpcontent2/source/text/shared/05/00000001.xhp
Comment 1 Ariel Constenla-Haile 2012-07-03 00:26:47 UTC
The code is in void SfxApplication::MiscExec_Impl( SfxRequest& rReq ) [main/sfx2/source/appl/appserv.cxx, near case SID_HELP_SUPPORTPAGE].

It creates a temporal help URL to get the Language and System arguments:

String sHelpURL = SfxHelp::CreateHelpURL( String::CreateFromAscii(".uno:HelpSupport"), String() );

The problem is that it uses a real, existing UNO command URL, so that SfxHelp::CreateHelpURL (SfxHelp::CreateHelpURL_Impl()) returns the help URL including the anchor:

vnd.sun.star.help://swriter/.uno%3AHelpSupport?Language=en-US&System=UNIX#bm_id3159176

This is the right anchor for that UNO commmand, in the help page main/helpcontent2/source/text/shared/main0108.xhp but is the root of the issue described here.
The code then takes this query part, including the anchor and appends it to the real help URL:

vnd.sun.star.help://shared/text/shared/05/00000001.xhp?Language=en-US&System=UNIX#bm_id3159176

but then also appends &UseDB=no

vnd.sun.star.help://shared/text/shared/05/00000001.xhp?Language=en-US&System=UNIX#bm_id3159176&UseDB=no

this ends up in a wrong System: "UNIX#bm_id3159176"
Comment 2 Ariel Constenla-Haile 2012-07-04 13:16:36 UTC
Fixed in revision 1357243
Comment 3 Javier Lopez 2013-02-16 00:51:36 UTC
This bug was checked in the platform W7 64 BITS with the version AOO 3.4.1 and this bug was not find.
Javier Lopez
Comment 4 Ariel Constenla-Haile 2013-02-21 10:43:16 UTC
(In reply to comment #3)
> This bug was checked in the platform W7 64 BITS with the version AOO 3.4.1
> and this bug was not find.

The fix wasn't included in 3.4.1, quite strange you find it fixed there. It is fixed on trunk.

Setting target milestone.
Comment 5 Ariel Constenla-Haile 2013-02-21 10:45:35 UTC
*** Issue 121807 has been marked as a duplicate of this issue. ***