Issue 120133 - [From Symphony]Doc file saved by AOO, section size changed
[From Symphony]Doc file saved by AOO, section size changed
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: open-import
3.4.0
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 01:48 UTC by Yan Ji
Modified: 2012-10-10 06:28 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (144.00 KB, application/msword)
2012-07-02 01:48 UTC, Yan Ji
no flags Details
Patch for 120133 (3.81 KB, patch)
2012-08-22 03:12 UTC, Chen Peng
chenpeng2006: review? (chengjh)
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-07-02 01:48:26 UTC
Created attachment 78528 [details]
sample

Build: AOO 3.4
Step:
1. Load sample file
2. Make some changes
3. Save as doc file
4. Reload saved doc file

Defect: Layout is inconsistent with MS Word.
Comment 1 Chen Peng 2012-08-22 03:11:20 UTC
1. Root Cause:
The section width should consider page and section indent value to calculate the right width size.

2. Resolution:
Get the indent value, then calculate the right section width.
Comment 2 Chen Peng 2012-08-22 03:12:12 UTC
Created attachment 79048 [details]
Patch for 120133
Comment 3 Yan Ji 2012-08-22 06:35:15 UTC
The original section size is : 3.92'', 5.67
After saved it to another doc file, section size changed to: 3.95'', 5.72''
Comment 4 Jian Hong Cheng 2012-09-04 09:40:42 UTC
The patch works after being applied..and is committed with revision:1380503.Thanks for the patch.
Comment 5 Du Jing 2012-09-20 07:24:57 UTC
verified on the build AOO3.5_r1387482
Comment 6 Shenfeng Liu 2012-10-10 06:28:15 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.