Issue 120102 - Crash in DomainMapperTableHandler
Crash in DomainMapperTableHandler
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: code
3.4.0
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 09:01 UTC by Andre
Modified: 2013-07-12 12:07 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andre 2012-06-27 09:01:39 UTC
When I tested the fix for bug 119557 I discovered a crash in DomainMapperTableHandler::endTableGetCellProperties(...).  To reproduce, load the bugdoc of bug 119557.  Crash during loading.

Note that this may only be reproducible with a non-pro and debug version.
Comment 1 Andre 2012-06-27 09:15:05 UTC
Root cause of the crash is an access to an empty vector via
   end()-1

The fix is simple: guard access by first testing for !empty().


SVN revision is 1354379.
Comment 2 Jianyuan Li 2012-06-28 02:24:56 UTC
@Andre:
The sample files provided in bug 119557 are all xls files. But your fix serves for xlsx file import. So maybe the bug number is written incorrectly in the description.
Any comments? If I am right, please correct the bug number to avoid misleading. Thanks.
Comment 3 Andre 2012-06-28 07:58:46 UTC
Ah, sorry, got one digit wrong.  It is bug 119577 that I was referring to.
Comment 4 binguo 2012-11-14 05:55:27 UTC
Verified on Aoo_Trunk_20121109.1800 rev 1407366
no crash occurs when open the sample file associated with Bug 119577.
Comment 5 binguo 2012-11-14 05:56:03 UTC
close it