Issue 120050 - [From Symphony] There is a memory leak in function SdPage::CreateTitleAndLayout
[From Symphony] There is a memory leak in function SdPage::CreateTitleAndLayout
Status: CLOSED FIXED
Product: performance
Classification: Code
Component: code
AOO 3.4.0
All All
: P3 normal (vote)
: AOO 4.0
Assigned To: Andre
:
Depends on:
Blocks: 120975 121366
  Show dependency treegraph
 
Reported: 2012-06-21 07:24 UTC by ChaoHuang
Modified: 2013-02-16 09:16 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
for file "main/sd/source/core/sdpage.cxx" (784 bytes, patch)
2012-06-21 07:59 UTC, ChaoHuang
awf.aoo: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description ChaoHuang 2012-06-21 07:24:03 UTC
Steps to reproduce the defect:
1) Launch Aoo3.4
2) New a odp file, close it

Defect : There is a memory leak in function SdPage::CreateTitleAndLayout
Comment 1 ChaoHuang 2012-06-21 07:27:46 UTC
The said SdrObject is not release when being removed from list in MasterPage. The UndoManager need to refer to it. In other case, it should be freed explicitly.
Comment 2 ChaoHuang 2012-06-21 07:59:37 UTC
Created attachment 78420 [details]
for file "main/sd/source/core/sdpage.cxx"
Comment 3 Andre 2012-06-21 13:27:25 UTC
Taking over for review.
Comment 4 Andre 2012-06-28 11:27:42 UTC
Comment on attachment 78420 [details]
for file "main/sd/source/core/sdpage.cxx"

Reviewed and commited in SVN revision 1354940.

I made small white space changes to move newlines where they belong.
Comment 5 Andre 2012-06-28 11:28:06 UTC
Setting status to resolved/fixed.
Comment 6 ChaoHuang 2012-10-17 08:13:34 UTC
Suggest to put it into AOO 3.5.0 release
Comment 7 Yan Ji 2012-11-30 04:47:21 UTC
Since last SVT(r1400866) shows there is no memory leak, so close this defect as resolved.