Issue 120049 - Aoo crash when modify the "Random effects" animation effect's trigger condition to "Start effect on click of"
Aoo crash when modify the "Random effects" animation effect's trigger conditi...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: ui
3.4.0
All All
: P3 normal (vote)
: 4.0.0
Assigned To: WangZhe
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 07:18 UTC by Tang Meng
Modified: 2013-07-11 15:22 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
1.odp (11.17 KB, application/x-zip-compressed)
2012-06-21 07:18 UTC, Tang Meng
no flags Details
patch (1.43 KB, patch)
2012-06-21 08:35 UTC, Tang Meng
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Tang Meng 2012-06-21 07:18:11 UTC
Created attachment 78415 [details]
1.odp

1.Launch Aoo, open the attached .odp document.
2.Invoke the "Effect Options" dialog via double click the animation effect, switch to "Timing" tab, select "Trigger->Start effect on click of->Title text '*' 1: *", then click "OK" button.

Defect: Aoo crash.
Comment 1 liuping 2012-06-21 07:31:19 UTC
confirm the bug
Comment 2 Tang Meng 2012-06-21 08:35:16 UTC
Created attachment 78421 [details]
patch
Comment 3 Tang Meng 2012-06-21 08:37:46 UTC
1. Root Cause:
When the "Effect Options" dialog is poping up, the "Text Animation" tab need update its value, and the “Animation Attached Shape” check box is changed and become disable, but its value is not same with the effect’s value, so Aoo treat it as a user action. And this action need access a Textgroup from effect sequence, but this sequence is a interactivesequence which just be created, and not rebuild yet, so a NULL textgroup is gotten, and cause crash.

2. Resolution:
Get value of “Animation Attached Shape” only when this checkbox is enabled.
Comment 4 WangZhe 2012-06-25 06:05:32 UTC
Delivered At revision: 1353393
Comment 5 Li Feng Wang 2012-08-30 06:15:12 UTC
Verify on AOo trunk r1378003. The crash is not exist.
But the title text can't display when slide show.

1)when list animation effect, then execute step2, the title text can display when slide show.
2)not list animation effect(open without any operation), then execute step2, the title text can't display when slide show.
Comment 6 Li Feng Wang 2012-08-30 07:19:30 UTC
This defect cover Crash problem. I open another defect to track display problem. (Bug 120756)