Issue 120039 - [From Symphony]the background of the file create from template 'blue_floral.otp' changed after save as the ppt or pot file
[From Symphony]the background of the file create from template 'blue_floral.o...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
: 119633 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 06:16 UTC by Du Jing
Modified: 2012-12-26 08:35 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (532.88 KB, application/x-rar-compressed)
2012-06-20 06:16 UTC, Du Jing
no flags Details
patch for bug 120039 (2.38 KB, patch)
2012-06-27 10:14 UTC, zjchen
awf.aoo: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2012-06-20 06:16:29 UTC
Created attachment 78399 [details]
sample file

Description:
1.launch AOO3.4 app 
2.import the template file into AOO
3.click main menu 'file->new->from template->presentation', select 'blue_floral.otp', click OK button
4.save as the ppt or pot file
5.reopen the ppt or pot file
***the background changed, pls see attachment
Comment 1 Yan Ji 2012-06-21 06:30:16 UTC
It can be reproduced in AOO 3.4, change status to "CONFIRMED"
Comment 2 zjchen 2012-06-27 10:06:39 UTC
The problem is that the feature is different between AOO and MSO about background fill type. Choose Fortmat -> Page, in Background tab, There are many parameters about background graphic on right side. From the result of my investigation, MSO doesn't support all these parameters in AOO. MSO 2003 support two kinds of background graphic: tile fill and area fill, MSO 2010 support more parameter but still cannot be completely mapping to those parameters in AOO.

There is one kind of special graphic background when you insert a picture background, and set the parameters as follows:
   graphic size Relative, both Width and Height 100%
   position X offset 0%, Y offset 0%
   row offset 0%, column offset 0%
then the background looks like a area fill type graphic, whether or not you choose the "Tile" check box.  
 
Considering the lack of background graphic parameter support in MSO, this special background should be area fill type not tiled fill type when export it into ppt file from my point of view.
Comment 3 zjchen 2012-06-27 10:14:21 UTC
Created attachment 78500 [details]
patch for bug 120039
Comment 4 Armin Le Grand 2012-06-27 12:28:21 UTC
ALG: You can use GraphicExporter with property "ExportOnlyBackground" to get the MasterPage fill as bitmap for all cases which ppt cannot directly export.
Comment 5 zjchen 2012-06-28 01:55:39 UTC
(In reply to comment #4)
> ALG: You can use GraphicExporter with property "ExportOnlyBackground" to get
> the MasterPage fill as bitmap for all cases which ppt cannot directly export.

-> ALG: Maybe I missed something. I thought the root cause of this issue is that a special tile fill background graphic need export as area fill type because MSO ppt only handle the background fill type property but ignore related parameters which can be modified in AOO. so I add a case to handle this special background fill type exporting process, and will not change the original bitmap. Could you give a little background to explain your idea? Thx in advance
Comment 6 Armin Le Grand 2012-06-28 09:09:30 UTC
ALG->zjchen: Yes, this was no comment for fixing this single case. I just thought all other cases (e.g. gradient, hatch, ...) are currently not exported correctly, so this would be a good occasion to fix that, too.
To do so, I would:

- detect if it can be exported
- if not, create bitmap for MasterPage background and setup export to use this created bitmap as replacement

This would not be perfect for the roundtrip, but all exports would look file at least.
Comment 7 SVN Robot 2012-07-09 12:57:57 UTC
"af" committed SVN 0: "#i120039# Export more bitmap fill style parameters.          Reported by: Du Jing          Patch by: zjchen          Review by: Andre Fischer"
Comment 8 Andre 2012-07-09 12:58:16 UTC
Comment on attachment 78500 [details]
patch for bug 120039

Reviewed and tested: OK
Comment 9 Andre 2012-07-09 13:04:33 UTC
Changed status to fixed.
Comment 10 Lei Debin 2012-07-19 01:51:16 UTC
*** Issue 119633 has been marked as a duplicate of this issue. ***
Comment 11 Li Feng Wang 2012-08-20 05:30:28 UTC
Verified pass on WindowsXP, Redhat 32bit,Mac with AOO trunk 0