Issue 120021 - [From Symphony] There is a memory leak in function PptSlidePersistEntry::~PptSlidePersistEntry()
[From Symphony] There is a memory leak in function PptSlidePersistEntry::~Ppt...
Status: CLOSED FIXED
Product: performance
Classification: Code
Component: code
AOO 3.4.0
All All
: P3 normal (vote)
: AOO 4.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks: 120975 121366
  Show dependency treegraph
 
Reported: 2012-06-18 08:05 UTC by ChaoHuang
Modified: 2013-02-16 09:19 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
for file "main/filter/source/msfilter/svdfppt.cxx" (568 bytes, patch)
2012-06-18 08:21 UTC, ChaoHuang
hdu: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description ChaoHuang 2012-06-18 08:05:22 UTC
Steps to reproduce the defect:
1) Launch Aoo3.4
2) Open a ppt file

Defect: There is a memory leak in function PptSlidePersistEntry::~PptSlidePersistEntry()
Comment 1 ChaoHuang 2012-06-18 08:09:12 UTC
There is no place to free member data pHeaderFooterEntry in class PptSlidePersistEntry. Need to release it explicitlt in destructor.
Comment 2 ChaoHuang 2012-06-18 08:21:51 UTC
Created attachment 78379 [details]
for file "main/filter/source/msfilter/svdfppt.cxx"
Comment 3 hdu@apache.org 2012-06-19 09:47:47 UTC
Thanks for finding this leak and for the patch to solve it!
Applied as 1351622.
Comment 4 Yan Ji 2012-11-30 04:47:32 UTC
Since last SVT(r1400866) shows there is no memory leak, so close this defect as resolved.