Issue 120019 - [From Symphony] There is a memory leak in function EmbeddedObjectRef::~EmbeddedObjectRef()
[From Symphony] There is a memory leak in function EmbeddedObjectRef::~Embedd...
Status: CLOSED FIXED
Product: performance
Classification: Code
Component: code
AOO 3.4.0
All All
: P3 normal (vote)
: AOO 4.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks: 120975 121366
  Show dependency treegraph
 
Reported: 2012-06-18 07:00 UTC by ChaoHuang
Modified: 2013-02-16 09:20 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
for file "main\svtools\source\misc\embedhlp.cxx" (504 bytes, patch)
2012-06-18 07:14 UTC, ChaoHuang
hdu: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description ChaoHuang 2012-06-18 07:00:30 UTC
Steps to reproduce the defect:
1) Launch Aoo3.4
2) New a odp file, save it
3) New a odt file, insert the odp file as an OLE object
4) Save the odt file, close it

Defect: There is a memory leak in function EmbeddedObjectRef::~EmbeddedObjectRef()
Comment 1 ChaoHuang 2012-06-18 07:03:46 UTC
The mpImp will be created in the constructor for class EmbeddedObjectRef. But it will not be released in destructor. Need to free it explicitly.
Comment 2 ChaoHuang 2012-06-18 07:14:08 UTC
Created attachment 78375 [details]
for file "main\svtools\source\misc\embedhlp.cxx"
Comment 3 hdu@apache.org 2012-06-19 10:02:03 UTC
Great find. The leak was probably introduced by a mis-pimpl-ification of the EmbeddedObjectRef class.
Applied as 1351632.
Comment 4 Yan Ji 2012-11-30 04:47:15 UTC
Since last SVT(r1400866) shows there is no memory leak, so close this defect as resolved.