Issue 120017 - [From Symphony]Filter is not shown in merged cell
[From Symphony]Filter is not shown in merged cell
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: editing
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: zhang jianfang
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 02:25 UTC by Yan Ji
Modified: 2012-12-18 06:24 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (6.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-06-18 02:28 UTC, Yan Ji
no flags Details
show filter button in merged cell (3.23 KB, patch)
2012-06-18 07:58 UTC, zhaoshzh
aoo.zhaoshzh: review?
Details | Diff
show filter button in merged cell (3.23 KB, patch)
2012-06-18 07:58 UTC, zhaoshzh
zhangjf: review+
Details | Diff
sample file (19.50 KB, application/vnd.ms-excel)
2012-12-18 06:24 UTC, Shenfeng Liu
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-06-18 02:25:45 UTC
Build: AOO3.4

Open attached sample file

Defect: The filter is not shown in cell A1 and D1 which is merged cell
Comment 1 Yan Ji 2012-06-18 02:28:24 UTC
Created attachment 78365 [details]
sample
Comment 2 zhaoshzh 2012-06-18 07:34:07 UTC
I am investigating this issue.
1. the root cause
OO does not show filter button when there is a merged cell.
and when user click on the cell,not show the popup window.

2. If a filter button is in the range of merged cell,show it when
the merge is in vertical, and show it in the last cell when
the merge is in horizental.

When a user click on the fitler,show it in the merged cell.

here is the patch.
Comment 3 zhaoshzh 2012-06-18 07:58:19 UTC
Created attachment 78376 [details]
show filter button in merged cell

show filter button in merged cell
Comment 4 zhaoshzh 2012-06-18 07:58:20 UTC
Created attachment 78377 [details]
show filter button in merged cell

show filter button in merged cell
Comment 5 zhang jianfang 2012-06-21 03:02:20 UTC
Comment on attachment 78377 [details]
show filter button in merged cell

I will review it.
Comment 6 zhang jianfang 2012-06-21 08:24:49 UTC
The patch is very good. Committed it to trunk by revision r1352444.
Comment 7 zhang jianfang 2012-06-21 08:25:39 UTC
Comment on attachment 78377 [details]
show filter button in merged cell

Set review pass flag.
Comment 8 Shan Zhu 2012-08-20 06:54:39 UTC
Verified on r1374181. It works.
Comment 9 Shenfeng Liu 2012-10-09 07:33:45 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.
Comment 10 Shenfeng Liu 2012-12-18 06:24:54 UTC
Created attachment 80039 [details]
sample file

add another sample file.