Issue 119999 - [From Symphony]Need press "ESC" key twice to exist chart edit mode
[From Symphony]Need press "ESC" key twice to exist chart edit mode
Status: CLOSED FIXED
Product: General
Classification: Code
Component: chart
OOo 3.3 or older
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 08:09 UTC by Yan Ji
Modified: 2013-07-11 13:35 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
patch for issue119999 (675 bytes, patch)
2012-06-19 05:22 UTC, Tan Li
litanbj: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-06-15 08:09:06 UTC
Build: AOO
Steps:
1. New writer document
2. From menu "Insert->Object->Chart"

Defect: Need press ESC key twice to exist chart edit mode.
Comment 1 Tan Li 2012-06-19 05:16:59 UTC
I have investigate this issue,
Root cause:
When create chart, code will select chart area by default. After creation, press first ESC will deselect chart area and second ESC  is needed to deactivate inplace mode.  For usability, select chart area by default has no advantage but bring redundant operation.

Resolution:
When create chart, don't  select chart area by default so that one ESC will deactivate inplace mode.
Comment 2 Tan Li 2012-06-19 05:22:58 UTC
Created attachment 78387 [details]
patch for issue119999
Comment 3 Armin Le Grand 2012-06-20 13:16:08 UTC
ALG: I agree, User experience will be better with a single ESC press needed. Applied, checked and works in all applications.
Comitted with 0. Thanks for the patch!
Comment 4 Shan Zhu 2012-08-20 05:22:37 UTC
Verified on 0. It works.
Comment 5 Shenfeng Liu 2012-11-07 08:40:03 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.