Issue 119988 - [Crash]AOO3.4 crash when modify the animation effect's Text Anmiation properties to "As one object" and check "Animate attached shape" option.
[Crash]AOO3.4 crash when modify the animation effect's Text Anmiation propert...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: editing
3.4.0
All All
: P3 critical (vote)
: 4.0.0
Assigned To: WangZhe
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 07:01 UTC by WangZhe
Modified: 2013-07-11 13:34 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
CustomAnimationPane.cxx in Code fix patch (75.67 KB, text/plain)
2012-06-14 07:32 UTC, WangZhe
kingwisemmx: review?
Details
Code fix patch (3.15 KB, patch)
2012-06-18 08:23 UTC, WangZhe
kingwisemmx: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description WangZhe 2012-06-14 07:01:34 UTC
Steps:
1.Launch AOO3.4, new a Presentation document, input a character into the title textbox.

2.Click on the blank space to exit edit mode, then select the title textbox, set an animation effect for it.

3.Switch to "Animation Effects" sidebar panel, slecet the effect that created in step 2, then click the "Effect Options" button.

4.In the poped "Effect Options" dialog, switch to "Text Animation" tab, select "Group text->All paragraphs at once", then click "OK" button.

5.Select the animation effect on side panel, invoke the "Effect Options" dialog, switch to "Text Animation" tab, select "Group text->As one object", check "Animate attached shape", then click "OK" button then check.  

Defect:AOO3.4 crash.
Comment 1 WangZhe 2012-06-14 07:32:07 UTC
Created attachment 78320 [details]
CustomAnimationPane.cxx in Code fix patch

1. Root Cause:
When set the animation "As one object", the text animation on the shape will be removed, and then do the animation transfer action will get a NULL pointer, and cause crash.

2. Resolution:
Should do the animation transifer first, then do the remove text animation action.

Detail Tech information pls see my patch
Comment 2 WangZhe 2012-06-18 08:23:26 UTC
Created attachment 78380 [details]
Code fix patch
Comment 3 Andre 2012-06-19 11:12:33 UTC
Taking over for review.
Comment 4 zhao xia 2012-06-20 05:49:09 UTC
Reproduced against Winows xp, confirmed.
Comment 5 WangZhe 2012-06-20 06:53:36 UTC
Resolved At revision: 1351945
Comment 6 Andre 2012-06-20 07:05:49 UTC
WhangZhe: I see that you have done the review yourself.  Please set the review flag accordingly.
Comment 7 Li Feng Wang 2012-08-30 06:31:14 UTC
Verify pass on AOO trunk r1378003.