Issue 119974 - [From Symphony]Ellipse shape display too large in MS office after save odp file to ppt format file
[From Symphony]Ellipse shape display too large in MS office after save odp fi...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: editing
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: WangZhe
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 03:24 UTC by Li Feng Wang
Modified: 2012-12-26 08:08 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (11.08 KB, application/vnd.oasis.opendocument.presentation)
2012-06-13 03:24 UTC, Li Feng Wang
no flags Details
Code fix patch (4.27 KB, patch)
2012-06-13 08:34 UTC, WangZhe
kingwisemmx: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-13 03:24:36 UTC
Created attachment 78274 [details]
sample file

build:
AOO3.4 release version

Steps:
1.Open the attached sample in AOO
2.Save it to ppt format file
3.Open the ppt file in MS Office 2003

Defect:
Ellipse display very large.
Comment 1 WangZhe 2012-06-13 08:34:09 UTC
Created attachment 78289 [details]
Code fix patch
Comment 2 Andre 2012-06-13 11:07:51 UTC
There is a lot of new code in your patch.  Can you give a short explanation of what it does and why it is necessary?
Comment 3 WangZhe 2012-06-19 07:59:08 UTC
There are two issues about this defect.
<1>Ellipse shape becomes bigger
Root Cause:
this sample is created by odf version 1.1 app.
the enhanced path for ellipse is the command "U" or "Z", the parameter is (x y w h t0 t1), it means that draws a segment of an ellipse. The ellipse is specified by the center(x, y), the size(w, h) and the start-angle t0 in degrees and end-angle t1 in degrees.
But in this odf(version 1.1) , w,h mean the diameter, in AOO3.4, it means the radius, so the ellipse created by odf version 1.1 app will becomes 2 times in Symphony Vienna.
2. Resolution:
In this case, the shape never use the default view box which is (0 0 21600 21600), but use (0 0 10000 10000). so if it is not the default view box, when draw a segment of ellipse, set the w & h in the enhanced path to half.
While there is a special senaria that odf version 1.1 app open a ms file,and saved it to odf file, because the ms filter use the preset shape design which viewbox is (0 0 21600 21600), so when export to odf file, it use the default viewbox, but the w, h in the U command parameters still means the diameter, so should check if the shape is from ms shape, that is the value of draw:type is started with "mso", and has the default viewbox, then set the w & h to half.

<2>Ellipse shape display too large in MS office after save odp file to ppt format file 
Root Cause:
The custom shape ellipse viewbox width and height value in odf version 1.1 are 10000, in odf version 1.2 are 21600. For example, when AOO3.4 importing a default ellipse object created by odf version 1.1 app, the ellipse default viewbox value will be ingored and using 10000 as the the viewbox value to compute. But the viewbox value in object model is not changed. So if saving the ellipse to ppt or odp by AOO3.4, the viewbox value will be 10000, but other values are based on 21600. 
Resolution:
If the ellipse is a default path object, but the viewbox value is not default one, set default viewbox value to the ellipse object model when importing by AOO3.4.
Comment 4 WangZhe 2012-06-20 06:51:56 UTC
Resolved At revision: 1351945
Comment 5 WangZhe 2012-06-20 06:56:22 UTC
Correct the revision: 1351947
> Resolved At revision: 1351945
Comment 6 Andre 2012-06-20 07:08:36 UTC
@WangZhe: It is good that you have done the review yourself as I do not have access to PowerPoint.  Please set the review flag accordingly.
Comment 7 louqle 2012-08-20 07:13:31 UTC
verified on XP SP3 and Ubuntu 12.04 against trunk build 1374181
Comment 8 louqle 2012-08-23 00:52:45 UTC
Verified on xp, Ubuntu, win7,mac,win7-64,Vista,suse,redhat, SLED 11 SP1 64 bit, all pass, close this bug
Comment 9 louqle 2012-08-23 00:52:58 UTC
close