Issue 119966 - [From Symphony] The Emphasis or Exit or Motion Path effect can not play if there is an Entrance effect after it.
[From Symphony] The Emphasis or Exit or Motion Path effect can not play if th...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 10:09 UTC by Steve Yin
Modified: 2012-12-26 08:49 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
The sample file created by Symphony 1.3 (154.99 KB, application/vnd.oasis.opendocument.presentation)
2012-06-12 10:09 UTC, Steve Yin
no flags Details
Fix patch for this issue (2.83 KB, patch)
2012-06-13 05:48 UTC, Steve Yin
awf.aoo: review+
Details | Diff
A sample file created by Microsoft PowerPoint 2010 (101.50 KB, application/vnd.ms-powerpoint)
2012-06-14 02:40 UTC, Steve Yin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Steve Yin 2012-06-12 10:09:36 UTC
Created attachment 78262 [details]
The sample file created by Symphony 1.3

Steps:
1.New a SD document by Symphony 1.3, then insert a shape.
2.Add an Emphasis or Exit or Motion Path animation effect for it, then add an Entrance effect. Save the document to an ODP file.
3.Launch AOO3.4, open the sample file,then play the screen show.

Defect: The object cannot be shown while playing the screen show, and the first animation effect is lost.
Comment 1 Steve Yin 2012-06-13 05:48:40 UTC
Created attachment 78278 [details]
Fix patch for this issue

Please help to review the patch.
Comment 2 Andre 2012-06-13 08:11:50 UTC
Reviewing.
Comment 3 Andre 2012-06-13 09:48:07 UTC
I think the core problem here is a shape that has two animations, the second of which makes the shape appear.  One could argue that it is no error when the shape is not visible during the first animation, that that is what the user requested.

With the patch applied the second animation is not visible anymore because it starts already visible.

By the way, this can be reproduced without importing a file from Symphony.  Just create a shape in a new presentation and assign two animations.  The first one from the Emphasis group, the second one an Entrance effect.
Comment 4 Steve Yin 2012-06-14 02:40:20 UTC
Created attachment 78307 [details]
A sample file created by Microsoft PowerPoint 2010
Comment 5 Steve Yin 2012-06-14 02:46:50 UTC
(In reply to comment #3)
> I think the core problem here is a shape that has two animations, the second
> of which makes the shape appear.  One could argue that it is no error when
> the shape is not visible during the first animation, that that is what the
> user requested.
> 
> With the patch applied the second animation is not visible anymore because
> it starts already visible.
> 
> By the way, this can be reproduced without importing a file from Symphony. 
> Just create a shape in a new presentation and assign two animations.  The
> first one from the Emphasis group, the second one an Entrance effect.

Hi Andre,

Comparing with MS PowerPoint, the different animation behaviors were found. You can try the 3rd attachment which is a sample file created by MS PowerPoint. Thanks.
Comment 6 Andre 2012-06-14 07:19:15 UTC
@Steve: In PowerPoint the behavior is different.  Both animations are displayed independently.  That means that before the second animation is started, the visibility of shape is turned off.

In AOO, without the fix the first effect is not visible because the shape is not yet visible.  With the fix the second effect is not visible, because the shape is already visible.
Comment 7 Steve Yin 2012-06-14 08:58:02 UTC
(In reply to comment #6)
> @Steve: In PowerPoint the behavior is different.  Both animations are
> displayed independently.  That means that before the second animation is
> started, the visibility of shape is turned off.
> 
> In AOO, without the fix the first effect is not visible because the shape is
> not yet visible.  With the fix the second effect is not visible, because the
> shape is already visible.

Hi Andre,

The 1st attachment file created by Symphony 1.3 may has interoperability issue with AOO. Please try to add animation effects with AOO. Same with what you said before, the 1st effect from the Emphasis group and the 2nd one from the Entrance group. Thanks.
Comment 8 Andre 2012-06-14 11:00:48 UTC
@Steve: I did AOO to create a document and reproduce the bug.  Again: without the patch the first animation is not visible, with patch the second animation is not visible.  Is that different on your system?
Comment 9 Steve Yin 2012-06-15 03:27:55 UTC
(In reply to comment #8)
> @Steve: I did AOO to create a document and reproduce the bug.  Again:
> without the patch the first animation is not visible, with patch the second
> animation is not visible.  Is that different on your system?

Hi Andre,

On my two Windows systems, one is Windows XP Pro SP3 32bit, the other is Windows 7 Pro SP1 64bit, with AOO Rev. 1327774 and Rev. 1345624. I found that opening the sample file created by Symphony 1.3 by AOO cannot show the second animation on the first slide with the patch. However on the other two slides all the animations can show correctly. If creating a new slide by AOO itself and adding two animations for one graphic object in the order, the second animation can show normally. If possible, could you upload your sample file? Thanks.
Comment 10 Andre 2012-06-15 07:13:18 UTC
You are right Steve, I tried it again and could not reproduce the problem anymore.  Maybe I just dreamed it :-)

I commited your patch on SVN revision 1350481.
Comment 11 Andre 2012-06-15 07:13:39 UTC
Comment on attachment 78278 [details]
Fix patch for this issue

Review done.
Comment 12 liuping 2012-06-21 09:16:49 UTC
Confirm fixing the bug on ver 1351249 in Win7 ,pass