Issue 119964 - [From Symphony]Number displays different from MS with the same format code
[From Symphony]Number displays different from MS with the same format code
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks: 120823
  Show dependency treegraph
 
Reported: 2012-06-12 08:55 UTC by Yan Ji
Modified: 2012-11-07 08:46 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (18.50 KB, application/octet-stream)
2012-06-12 08:55 UTC, Yan Ji
no flags Details
Add patch (1.98 KB, patch)
2012-06-14 05:22 UTC, Zhang Lu
zhanglu.aoo: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-06-12 08:55:06 UTC
Created attachment 78260 [details]
sample

MS displays the two Format code with the same result, but AOO doesn't, please see cell A1 and A2

[>0][BLUE]#.0;[<0][RED]#.0;[GREEN]#.000

[<0][RED]#.0;[=0][GREEN]#.000;[BLUE]#.0
Comment 1 Zhang Lu 2012-06-14 05:22:02 UTC
Created attachment 78315 [details]
Add patch

Root Cause:
AOO will ignore the <0 condition if appear in first scetion
Resolution:
To check the condition of first section, if meet condition, remove the minus sign
Comment 2 Wang Lei 2012-06-21 02:43:36 UTC
I will review it
Comment 3 Wang Lei 2012-06-21 07:27:56 UTC
Reviewed.  Patch looks good.
Thanks for the good work.
Applied on SVN 0
Comment 4 binguo 2012-08-20 09:43:43 UTC
Verified on latest AOO Trunk 0817 build on Window OS/Linux OS/Linux 64bit OS, this bug is fixed. Format code in cells A1 and A2 are correct.
Comment 5 Shenfeng Liu 2012-11-07 08:46:18 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.