Issue 119962 - [From Symphony]Placeholder in ppt file created by MS 2007 is lost if load in Impress
[From Symphony]Placeholder in ppt file created by MS 2007 is lost if load in ...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
3.4.0
PC All
: P3 major (vote)
: 4.0.0
Assigned To: WangZhe
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 08:30 UTC by Yan Ji
Modified: 2012-10-18 07:02 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (100.50 KB, application/vnd.ms-powerpoint)
2012-06-12 08:30 UTC, Yan Ji
no flags Details
patch (797 bytes, patch)
2012-09-04 02:50 UTC, Tang Meng
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-06-12 08:30:18 UTC
Created attachment 78255 [details]
sample

Build: AOO3.4

Load sample file, the place holder cannot be shown
Comment 1 Tang Meng 2012-08-27 05:19:10 UTC
I am looking at this bug.
Comment 2 Tang Meng 2012-09-04 02:50:33 UTC
Created attachment 79281 [details]
patch

1. Root Cause:
when an empty pptx file convert to a ppt file. There is an empty paragraph in the text object, so this text object hasn't been set a placeholder. But we can't see an empty paragraph, so we see nothing.
2. Resolution:
Set this empty text object a placeholder.
Comment 3 WangZhe 2012-09-07 04:41:49 UTC
I'll take this one
Comment 4 WangZhe 2012-09-07 05:24:31 UTC
Deliver At revision: 1381878
Comment 5 Li Feng Wang 2012-09-18 08:29:49 UTC
placeholder can display normally on trunk 0
Comment 6 Shenfeng Liu 2012-10-18 07:02:27 UTC
Update Target Milestone to AOO 3.5.0.