Issue 119959 - [From Symphony]Application crashed if undo paste text from shape
[From Symphony]Application crashed if undo paste text from shape
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: editing
3.4.0
PC All
: P3 critical (vote)
: 4.1.0
Assigned To: AOO issues mailing list
Clarence GUO
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 07:58 UTC by Yan Ji
Modified: 2014-04-03 07:37 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
This patch is only for the crash problem. (1.38 KB, patch)
2012-06-13 01:55 UTC, Jian Hong Cheng
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-06-12 07:58:10 UTC
Build: AOO3.4
Steps:
1. New a text document
2. Click "Bullet" button in toolbar to enable bullet to empty paragraph
3. Draw a shape and enter several line into shape, select and copy the text
4. Paste text to doc which has bullet
5. Undo/Redo

Defect: Application crashed
Comment 1 Jian Hong Cheng 2012-06-13 01:50:39 UTC
The reason is that when there are multiple paragraphs within the drawing,only the first paragraph will be applied bullets after being pasted..Thus,if getting number rule from txt node and being referenced directly,to the txt nodes from the second, crash problem will occur.
Comment 2 Jian Hong Cheng 2012-06-13 01:55:27 UTC
Created attachment 78269 [details]
This patch is only for the crash problem.

This patch will only solve the crash problem..The problem that the contents from the second txt node have not been applied bullets will not be included..Need new issue to trace it..
Comment 3 Jian Hong Cheng 2012-06-13 02:10:23 UTC
Committed with revision:1349609
Comment 4 binguo 2012-06-19 07:17:32 UTC
Verified it on Aoo_Trunk_20120616.1800.1350879 and it does not reproduce, so close it as fixed.
Comment 5 Shenfeng Liu 2012-10-09 09:33:27 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.
Comment 6 Oliver-Rainer Wittmann 2013-11-01 11:16:50 UTC
The patch does not fix the root cause as the assertion in the code state that the non-existence of the list style is a serious defect.

I have found the root cause. The RTF filter which is used on copy-and-paste does not resets the list attribute when it resets the list style. Thus, the paragraph's attributes are not consistent. This causes trouble on the Redo.
Comment 7 SVN Robot 2013-11-01 11:37:47 UTC
"orw" committed SVN revision 1537903 into trunk:
119959: <SwRTFParser::SetAttrInDoc(..)> - reset list attributes, if needed
Comment 8 Oliver-Rainer Wittmann 2013-11-01 12:08:03 UTC
fixed root cause on trunk for AOO 4.1.0

please verify this issue again for AOO 4.1.0
Comment 9 Clarence GUO 2014-02-26 01:51:02 UTC
Verified on snapshot Rev.1566593, the defect was resolved.
Comment 10 fanyuzhen 2014-02-27 01:46:37 UTC
Change defect status per Clarence Guo's comment
Comment 11 Steve Yin 2014-04-03 07:37:57 UTC
Verified on branch AOO410. Rev. 1583666