Issue 119922 - [From Symphony]Graphic in header and footer can not be displayed correctly
[From Symphony]Graphic in header and footer can not be displayed correctly
Status: VERIFIED FIXED
Product: Writer
Classification: Application
Component: ui
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 08:45 UTC by Yan Ji
Modified: 2012-10-09 09:35 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (476.48 KB, application/octet-stream)
2012-06-08 08:52 UTC, Yan Ji
no flags Details
Fix for graphic didn't display correctly in header/footer. (3.15 KB, patch)
2012-06-11 02:57 UTC, kang jian
jane73_kang: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-06-08 08:45:51 UTC
Build AOO3.4

Open sample file, check the graphic in header footer.

Defect: Graphic in Header and Footer can not be displayed completely.

This is because "Instantly fit the height" check box in Header tab in Page Properties dialog does not work.
Comment 1 Yan Ji 2012-06-08 08:52:39 UTC
Created attachment 78196 [details]
sample
Comment 2 kang jian 2012-06-11 02:57:32 UTC
Created attachment 78224 [details]
Fix for graphic didn't display correctly in header/footer.

Root cause:
The "Follow text flow" property wasn't supported in previous version.So when the doc was opened in the latest version, default value for this property was set to true.This will result in that graphic in the header/footer wasn't displayed correctly. 

Solution:
Set "Follow text flow" to false for the previous version that didn't support "Follow text flow", when open it in the latest version.

Unit test:
  Test 1:
       1.Open the sample file in the build with fixed.
  Test 2:
       1.Tried insert some picture into header/footer/body.
  Test 3:
       1.Open the sample file in the build with fixed.
       2.Set the page body large enough.And Writer didn't hang.
Comment 3 Jian Hong Cheng 2012-06-26 01:30:29 UTC
Reviewed and Committed with Revision:1353791..Thanks for the patch.
Comment 4 Du Jing 2012-08-20 09:55:36 UTC
verified on the AOO3.5_r1374181
Comment 5 Shenfeng Liu 2012-10-09 09:35:35 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.