Issue 119907 - [From Symphony] Number formating are changed after save and reopen it again.
[From Symphony] Number formating are changed after save and reopen it again.
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
: 119662 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 04:16 UTC by Steve Yin
Modified: 2012-12-26 08:45 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (11.86 KB, application/vnd.oasis.opendocument.presentation)
2012-06-08 04:16 UTC, Steve Yin
no flags Details
Fix patch for this issue (734 bytes, patch)
2012-06-08 04:32 UTC, Steve Yin
steve.yin.aoo: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Steve Yin 2012-06-08 04:16:08 UTC
Created attachment 78170 [details]
sample file

Reproducible steps:
1. New a presentation.
2. Input some content in "add text" frame, then set JA numberring.
3. Save it and reopen it again.
Comment 1 Steve Yin 2012-06-08 04:32:12 UTC
Created attachment 78171 [details]
Fix patch for this issue

Root Cause:
There is a 'switch case' statement which limits the numbering types in SvxUnoNumberingRules::setNumberingRuleByIndex

Resolution:
Just remove the 'switch case' statement.
Comment 2 Andre 2012-06-08 07:18:06 UTC
@Steve Yin: Can you explain how to use JA numbering?
Comment 3 Steve Yin 2012-06-08 09:55:58 UTC
(In reply to comment #2)
> @Steve Yin: Can you explain how to use JA numbering?
Hi Andre,

First, open the 'Bullets and Numbering' dialog then switch to the 'Customize' tab. You can select JA numbering or Chinese numbering by the 'Numbering' dropdown control.
Comment 4 Andre 2012-06-08 11:38:10 UTC
Reviewed, tested and committed.  Did some additional cleanup: removed the commented out code.
SVN revision is 1348028
Comment 5 jsc 2012-06-08 12:07:43 UTC
*** Issue 119662 has been marked as a duplicate of this issue. ***
Comment 6 liuping 2012-06-21 08:35:05 UTC
confirm fixing the bug on ver 1351249 in Win7 ,pass