Issue 119889 - [From Symphony] Import .pptx file into OO3.4, the vertical text direction of the table will be lost.
[From Symphony] Import .pptx file into OO3.4, the vertical text direction of ...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: jsc
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 10:00 UTC by Shan Zhu
Modified: 2012-12-26 08:42 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
.pptx sample has a table with vertical text in (36.06 KB, application/vnd.ms-powerpoint.presentation.12)
2012-06-07 10:00 UTC, Shan Zhu
no flags Details
patch for vertical text in table from pptx (1.55 KB, patch)
2012-06-07 10:07 UTC, bjcheny
companycy: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Shan Zhu 2012-06-07 10:00:23 UTC
Created attachment 78142 [details]
.pptx sample has a table with vertical text in

Build info: AOO3.4_r1327774

Steps:
1. Launch MS Office 2007,new a SD document,insert a table,input some text in the cell,then select and set "text direction" to "vertical",save it as a .pptx document. (A sample file attached for your reference)
2.Open the attached .pptx file in OO3.4.

Issue:
The vertical text setting lost.
Comment 1 bjcheny 2012-06-07 10:04:29 UTC
1. Root Cause:
The oox module imports the cell vertical property but doesn't set it.

2. Resolution:
Set property to cell object if the cell has vertical property. And fix in svx module by setting cell's vertical property.
Comment 2 bjcheny 2012-06-07 10:07:33 UTC
Created attachment 78143 [details]
patch for vertical text in table from pptx

It involves 2 modules oox and svx.
In oox, it needs to pass vertical property to sd in tablecell.cxx.
In svx, it needs set vertical property for cell object in cell.cxx.
Comment 3 jsc 2012-06-08 12:32:04 UTC
reviewed, built and tested, patch applied on trunk

trunk -> revision 1348039
Comment 4 liuping 2012-06-25 02:55:21 UTC
confirm fixing the bug on ver 1351249 in Win7 ,pass