Issue 119888 - [From Symphony]Shape border and fill color lost if open the ppt doc via AOO
[From Symphony]Shape border and fill color lost if open the ppt doc via AOO
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: formatting
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 09:57 UTC by Li Feng Wang
Modified: 2012-12-26 08:02 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (18.50 KB, application/vnd.ms-powerpoint)
2012-06-07 09:57 UTC, Li Feng Wang
no flags Details
Patch for this issue (597 bytes, patch)
2012-07-09 01:54 UTC, Jianyuan Li
awf.aoo: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-07 09:57:12 UTC
Created attachment 78141 [details]
sample file

build:
AOO3.4 r1327774

steps:
1.Launch AOO, open the attached ppt doc.
2.Check the fill color of the shapes.

Defect:
 The gradient and solid fill color changed to white in AOO
Comment 1 Jianyuan Li 2012-07-03 02:22:04 UTC
I am investigating this issue
Comment 2 Jianyuan Li 2012-07-03 09:25:59 UTC
Root cause:
Generally speaking, there are two kinds of shapes which are indicated by "Instance" section in binary file. "0" means custom shape. "1~202" mean auto shape. See more details in "MS-ODRAW.odf". The main difference for the two kinds of shape is custom shape must have "path" properties for illustrating. So two key properties "pSegmentInfo" and "pVertices" must exist for custom shape. For shapes in sample file, their instances do not belong to any kinds of above. It is mso_sptNil for which shape properties will not be set into core function.
Solution:
The sample shapes are a little weird. I cannot create such kind of shapes. Maybe they are obtained from some transformation(filter). So here just add a condition to handle this kind of shape. The condition is to check whether the key property "pVertices" exists or not.
Comment 3 Jianyuan Li 2012-07-09 01:54:13 UTC
Created attachment 78592 [details]
Patch for this issue
Comment 4 Andre 2012-07-09 12:05:12 UTC
Comment on attachment 78592 [details]
Patch for this issue

Reviewed and tested, OK.
Comment 5 Andre 2012-07-09 12:05:53 UTC
SVN revision is 1359095.
Comment 6 louqle 2012-08-20 02:40:51 UTC
verified on XP SP3 and Ubuntu 12.04 against trunk build 1374181
Comment 7 louqle 2012-08-23 00:53:52 UTC
Verified on xp, Ubuntu, win7,mac,win7-64,Vista,suse,redhat, SLED 11 SP1 64 bit, all pass, close this bug