Issue 119887 - [From Symphony]Shape shadow position changed incorrect if open the ppt doc via AOO
[From Symphony]Shape shadow position changed incorrect if open the ppt doc vi...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: editing
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 09:46 UTC by Li Feng Wang
Modified: 2012-12-26 08:00 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (118.00 KB, application/vnd.ms-powerpoint)
2012-06-07 09:46 UTC, Li Feng Wang
no flags Details
Patch for this issue (816 bytes, patch)
2012-07-03 07:13 UTC, Jianyuan Li
awf.aoo: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-07 09:46:52 UTC
Created attachment 78139 [details]
sample file

build:
AOO3.4 r1327774

steps:
1.Launch AOO, open the attached .ppt doc.
2.Check the position of the shadow.

Defect: The shadow position is different from that in MS Office.
Comment 1 Jianyuan Li 2012-07-02 02:45:54 UTC
I am investigating this issue.
Comment 2 Jianyuan Li 2012-07-02 07:59:12 UTC
Root cause:
if shadowOffsetY and shadowOffsetX are not exist, they will not be handled. if they exist, value 0 will be a valid value which should not be ignored. Related item should be set into core function. Or a default value will be used by core function. 
Solution:
set the shadow position x or y no matter it is 0 or not.
Comment 3 Jianyuan Li 2012-07-03 07:13:59 UTC
Created attachment 78560 [details]
Patch for this issue
Comment 4 Andre 2012-07-06 13:05:35 UTC
Taking over.
Comment 5 Andre 2012-07-06 13:08:17 UTC
Comment on attachment 78560 [details]
Patch for this issue

Reviewed and tested.  OK.
Comment 6 Andre 2012-07-06 13:08:53 UTC
SVN revision is 1358177.
Comment 7 louqle 2012-08-20 03:30:37 UTC
verified on XP SP3 and Ubuntu 12.04 against trunk build 1374181
Comment 8 louqle 2012-08-23 00:54:13 UTC
Verified on xp, Ubuntu, win7,mac,win7-64,Vista,suse,redhat, SLED 11 SP1 64 bit, all pass, close this bug