Issue 119885 - PPT Import:textbox lost part of text in AOO
PPT Import:textbox lost part of text in AOO
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: Armin Le Grand
:
Depends on:
Blocks: 120823
  Show dependency treegraph
 
Reported: 2012-06-07 09:41 UTC by liuping
Modified: 2013-07-12 16:17 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (26.50 KB, application/vnd.ms-powerpoint)
2012-06-07 09:41 UTC, liuping
no flags Details
capture.png (197.87 KB, image/png)
2012-06-07 09:41 UTC, liuping
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2012-06-07 09:41:09 UTC
Created attachment 78136 [details]
sample file

build: AOO3.4 rev 1327774


Description:

1. open the attached sample file in AOO and MS
2. check the text in textbox in AOO and compare it with the one in Microsoft Excel

Defect:
textbox lost part of text in AOO 

pls refer the capture.png
Comment 1 liuping 2012-06-07 09:41:39 UTC
Created attachment 78137 [details]
capture.png
Comment 2 Maaret Pyhäjärvi 2012-06-09 18:51:38 UTC
9.6.2012 on OOo 3.4.0 AOO340m(Build:9590) - Rev. 1325589:

I can reproduce the issue for Powerpoint 2007 --> Impress 3.4.0 on WinXP. 
For MS Powerpoint, it is possible to resize the textbox background to create slides where the background color appears only on top part of the text. For OOo Impress, the background is fit to the text. Due to lower part of text and the background being similar in color, the text that is shown as desired in Powerpoint vanishes in Impress.
Comment 3 zhao xia 2012-06-12 06:36:32 UTC
I reproduced this issue on Windows XP against AOO3.4 publish build.
Comment 4 Armin Le Grand 2012-10-05 12:35:20 UTC
ALG: Taking a look...
Comment 5 Armin Le Grand 2012-10-05 12:39:51 UTC
ALG: Indeed, all is imported, but the lower text is not visible because the text box grew in size due to it's AutoGrowHeight state. Does it make sense to allow writing text outside the text frame at all?
Checked PPT, there it is allowed (and used in this case). With new impress, the props of the std text frames can be manipulated to switch off AutoGrowHeight, so it is possible in AOO3.4.1, too. There is one caveat: The outside text is visible in view mode, but clipped in edit mode. This may be a problem...
Comment 6 Armin Le Grand 2012-10-05 13:08:18 UTC
ALG: Found the place to act; it's filter/source/msfilter/svdfppt.cxx ln 1179. There, not bFitShapeToText is used, but bAutoGrowHeight is set to true hard. There is also a comment:

// bFitShapeToText;	can't be used, because we cut the text if it is too height,

This hints on a fix, but at the same time five lines above bFitShapeToText *is* used, even with the same comment added. This hints on a misleading fix. Checking the mozilla database gives no further hints, and there is no bug number given. svn blame also knows nothing else. Looking into older repos...
Comment 7 Armin Le Grand 2012-10-05 13:57:38 UTC
ALG: Older repos show that it's a pretty old fix from Sven, but no specific scenario given. I think it's worth a try to fix this in the described place. 

Remaining will be that the edit mode does not show text outsid ethe object (other than edit mode for draw objects, there text outside the shape is visible). Taking a look...
Comment 8 SVN Robot 2012-10-05 14:02:55 UTC
"alg" committed SVN revision 1394533 into trunk:
#119885# corrected AutoGrowHeight setting when importing PPT text boxes
Comment 9 Armin Le Grand 2012-10-05 14:03:36 UTC
ALG: Okay, import working now (checked again: old change was from 2005). Looking into text edit mode...
Comment 10 Armin Le Grand 2012-10-05 16:01:25 UTC
ALG: There is a possibility, the place is svx/source/svdraw/svdotext.cxx line 865; there, SetMaxAutoPaperSize should only set hor for hor text and ver for ver text and keep the other value on default (100000?). I have to think about that...
Comment 11 Armin Le Grand 2012-10-08 16:11:47 UTC
ALG: After some experimenting I found a working solution; it keeps editing extended when AutoGrowHeight or !IsVerticalWriting is true, adapted this in various places. Also had to adapt the invalidatin on EditEngine expand (was only done for getting smaller). All together works well. Checking in...
Comment 12 SVN Robot 2012-10-08 16:14:01 UTC
"alg" committed SVN revision 1395635 into trunk:
#119885# Made EditMode work with text boxes where text is reaching over the T...
Comment 13 Armin Le Grand 2012-10-08 16:16:03 UTC
ALG: Wrote #121187# for further EditEngine tasks. Done so far.
Comment 14 binguo 2012-11-16 05:50:43 UTC
Verified on Aoo_Trunk_20121109.1800 Rev.1407366
pass, text display correctly.
Comment 15 binguo 2012-11-16 05:52:17 UTC
close it.