Issue 119884 - [From Symphony]Fontwork alignment changes after saving to another ppt with AOO
[From Symphony]Fontwork alignment changes after saving to another ppt with AOO
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: editing
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 09:30 UTC by Li Feng Wang
Modified: 2012-12-26 07:59 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (98.00 KB, application/vnd.ms-powerpoint)
2012-06-07 09:30 UTC, Li Feng Wang
no flags Details
patch for export fontwork alignment error (2.06 KB, patch)
2012-07-02 05:57 UTC, SunYing
awf.aoo: review+
Details | Diff
UT sample file (39.97 KB, application/x-zip-compressed)
2012-07-02 08:52 UTC, SunYing
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-07 09:30:45 UTC
Created attachment 78135 [details]
sample file

build:
AOO3.4 r1327774

steps:
1. Launch AOO
2. Open the attached .ppt file    
3. Save it to another .ppt file
4. Reopen it with both AOO and ms powerpoint
5. Check Fontwork alignment in the slide 1.

Defect:the Fontwork changes from Left alignment to Center alignment after saved by AOO.
Comment 1 SunYing 2012-06-28 06:35:44 UTC
I'm checking this defect.
Comment 2 SunYing 2012-07-02 05:56:40 UTC
root cause:
Did not export alignment for font work.
Comment 3 SunYing 2012-07-02 05:57:58 UTC
Created attachment 78535 [details]
patch for export fontwork alignment error

solution:
export the alignment attr when export font work.
Comment 4 SunYing 2012-07-02 08:52:39 UTC
Created attachment 78544 [details]
UT sample file
Comment 5 SVN Robot 2012-07-06 14:02:07 UTC
"af" committed revision 1358218: "#i119884# Fixed export of fontwork alignment.          Reported by: Li Feng Wang          Patch by: SunYing          Review by: Andre Fischer"
	incubator/ooo/trunk/main/filter/source/msfilter/
Comment 6 Andre 2012-07-06 14:02:51 UTC
Taking over ownership.
Comment 7 Andre 2012-07-06 14:03:51 UTC
Comment on attachment 78535 [details]
patch for export fontwork alignment error

Reviewed and tested: OK
Comment 8 Andre 2012-07-06 14:04:41 UTC
Fixed in SVN revision 1358218.
Comment 9 louqle 2012-08-20 03:28:35 UTC
verified on XP SP3 and Ubuntu 12.04 against trunk build 1374181
Comment 10 louqle 2012-08-23 00:54:37 UTC
Verified on xp, Ubuntu, win7,mac,win7-64,Vista,suse,redhat, SLED 11 SP1 64 bit, all pass, close this bug