Issue 119875 - [From Symphony] Vertical text direction in table cell change to horizontal after saving to another .ppt by AOO
[From Symphony] Vertical text direction in table cell change to horizontal a...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: formatting
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 08:59 UTC by Li Feng Wang
Modified: 2012-12-26 07:33 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (16.50 KB, application/vnd.ms-powerpoint)
2012-06-07 08:59 UTC, Li Feng Wang
no flags Details
UT sample file (35.00 KB, application/vnd.ms-powerpoint)
2012-08-02 08:10 UTC, SunYing
no flags Details
patch for ppt export table font alignment error (1.32 KB, patch)
2012-08-02 08:11 UTC, SunYing
sunyingshadesun: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-07 08:59:17 UTC
Created attachment 78124 [details]
sample file

build:
AOO3.4 r1327774

steps:
1.Launch AOO
2.Open the sample file
3.Save the sample file as *.ppt in AOO
4.Reopen the saved *.ppt in AOO

Defect:
Vertical text direction in some table cells changes to horizontal
Comment 1 SunYing 2012-08-01 06:25:19 UTC
I'm checking this defect.
Comment 2 SunYing 2012-08-02 01:57:34 UTC
Root Cause:
Did not set WritingMode and TextHorizontalAdjust properties when import table cell.
Comment 3 SunYing 2012-08-02 08:09:34 UTC
Resolution:
set WritingMode properties when import table cell.
Comment 4 SunYing 2012-08-02 08:10:34 UTC
Created attachment 78821 [details]
UT sample file
Comment 5 SunYing 2012-08-02 08:11:40 UTC
Created attachment 78822 [details]
patch for ppt export table font alignment error
Comment 6 Jianyuan Li 2012-08-14 08:37:45 UTC
Reviewed and looks good.
Comment 7 SVN Robot 2012-08-16 03:14:07 UTC
"sunying" committed SVN revision 1373715 into trunk:
#119875# fix vertical text direction in table cell change when save .ppt file...
Comment 8 sunying 2012-08-20 01:49:53 UTC
This issue has been fixed.
Comment 9 louqle 2012-08-24 04:30:42 UTC
verified on Ubuntu 12.04, XP SP3, Vista, Win7, Win7 64-bit, Suse 11 SP1, Redhat 6.1, Mac 10.7 against build 1376366,

SLED 11 SP1 64 bit against build 1376353

Pass. Close this bug