Issue 119874 - [From Symphony]The vertical text alignment of the placeholder is wrong while opening the ppt file in AOO
[From Symphony]The vertical text alignment of the placeholder is wrong while ...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: formatting
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 08:50 UTC by Li Feng Wang
Modified: 2012-12-26 08:09 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (15.50 KB, application/vnd.ms-powerpoint)
2012-06-07 08:50 UTC, Li Feng Wang
no flags Details
UT files for this defect (6.99 KB, application/x-zip-compressed)
2012-06-28 08:19 UTC, Jianyuan Li
no flags Details
Patch for this issue (5.60 KB, patch)
2012-06-28 08:47 UTC, Jianyuan Li
awf.aoo: review+
Details | Diff
failed on Mac 10.7 (167.53 KB, image/png)
2012-08-21 07:23 UTC, louqle
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-07 08:50:55 UTC
Created attachment 78122 [details]
sample file

build:
AOO3.4 r1327774

steps:
1. Launch AOO and open the attachment .ppt file
2. Check the text alignment of the placeholder  with it in the Powerpoint 

Defect: 
The vertical text alignment of the placeholder is wrong.
Comment 1 Jianyuan Li 2012-06-28 01:40:14 UTC
I am investigating this issue.
Comment 2 Jianyuan Li 2012-06-28 08:16:45 UTC
Root cause: For the placeholder with default text, its alignment is not handled when import
Solution: When import, according to text flow and text anchor, set the horizontal and vertical default text alignment.
Limitation:
There are still some layout import issues which will impact the verification of the fix. If the alignment is not the default alignment of the sd layout, the place holder border and default text will not be imported. The place holder will be hidden. So to verify the fix, input some words in the hidden place holder.
Comment 3 Jianyuan Li 2012-06-28 08:19:38 UTC
Created attachment 78510 [details]
UT files for this defect
Comment 4 Jianyuan Li 2012-06-28 08:47:34 UTC
Created attachment 78511 [details]
Patch for this issue
Comment 5 SunYing 2012-07-09 03:16:16 UTC
patch looks good and test passed.
Comment 6 Andre 2012-07-09 11:36:17 UTC
One question regarding line 7829

    bVerticalText = !bVerticalText;

Is this, in this context, just a fancy way of setting bVerticalText to sal_True?
Comment 7 Jianyuan Li 2012-07-11 01:32:59 UTC
(In reply to comment #6)
> One question regarding line 7829
> 
>     bVerticalText = !bVerticalText;
> 
> Is this, in this context, just a fancy way of setting bVerticalText to
> sal_True?
In the very beginning, there are some other handling for bVerticalText. So it is handled like that. When code is committed, it can be set as sal_True.
Comment 8 Andre 2012-07-11 08:20:08 UTC
The patch fixes the vertical alignment (in the context of the document being rotated by 90 degrees) but the horizontal alignment is still wrong: the bullet point is not completely inside the text shape.

A second difference to PowerPoint is that the two shapes (title and text) intersect where there is a clear gap in PowerPoint.
Comment 9 Jianyuan Li 2012-07-13 08:21:16 UTC
(In reply to comment #8)
> The patch fixes the vertical alignment (in the context of the document being
> rotated by 90 degrees) but the horizontal alignment is still wrong: the
> bullet point is not completely inside the text shape.
> 
> A second difference to PowerPoint is that the two shapes (title and text)
> intersect where there is a clear gap in PowerPoint.
Yes, really they are not fixed in my patch. But I think they are out of the scope for this issue.
Comment 10 Andre 2012-07-13 08:56:20 UTC
Comment on attachment 78511 [details]
Patch for this issue

Reviewed and tested: OK.
Remaining problems are unrelated.
Comment 11 Andre 2012-07-13 09:01:27 UTC
Fixed.
Comment 12 SVN Robot 2012-07-13 09:01:39 UTC
"af" committed SVN revision 1361109 into branches/AOO34:
#i119874# Fixed text alignment in RTL layout.
Comment 13 Andre 2012-07-13 09:07:50 UTC
Contrary to what the SVN bot wrote, the change was committed into trunk NOT to branches/AOO34.
Comment 14 Jianyuan Li 2012-07-26 08:18:40 UTC
@Andre,
Seems a part of patch(changes for this file "sd/source/filter/ppt/pptin.cxx") is lost in your commitment. Please help commit that.
Comment 15 SVN Robot 2012-07-26 10:00:49 UTC
"af" committed SVN revision 1365930 into trunk:
#i119874# Missing part of patch.
Comment 16 Andre 2012-07-26 10:02:07 UTC
Good catch.
Done.
Comment 17 louqle 2012-08-20 02:51:32 UTC
verified on XP SP3 and Ubuntu 12.04 against trunk build 1374181
Comment 18 louqle 2012-08-21 07:23:57 UTC
Created attachment 79031 [details]
failed on Mac 10.7
Comment 19 louqle 2012-08-21 07:24:33 UTC
fail on Mac 10.7, reopen
Comment 20 Jianyuan Li 2012-08-22 08:17:41 UTC
This issue focus on the horizontal and vertical alignment.Vertical text showing issue will be tracked by Bug 119474. So Please close this defect because the focus issue has been fixed.
Comment 21 louqle 2012-08-23 00:57:31 UTC
Verified on xp, Ubuntu, win7,mac,win7-64,Vista,suse,redhat, SLED 11 SP1 64 bit, the alignment is correct. Please change to resolved again then I can close it.
Comment 22 Jianyuan Li 2012-08-23 01:26:06 UTC
horizontal and vertical alignment issue has been fixed
Comment 23 Jianyuan Li 2012-08-24 01:15:52 UTC
@louqle:
Please close this bug. Thanks.
Comment 24 louqle 2012-08-27 03:17:30 UTC
close this bug according to comments 20&21