Issue 119872 - [From Symphony]all drawing objects lost aftering saving to another ppt by AOO
[From Symphony]all drawing objects lost aftering saving to another ppt by AOO
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: editing
3.4.0
PC All
: P1 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
: 119778 119879 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 08:43 UTC by Li Feng Wang
Modified: 2012-10-02 09:51 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (25.50 KB, application/vnd.ms-powerpoint)
2012-06-07 08:43 UTC, Li Feng Wang
no flags Details
root cause analysis for this issue (12.84 KB, application/vnd.oasis.opendocument.text)
2012-07-10 03:22 UTC, Jianyuan Li
no flags Details
UT file for this issue (22.00 KB, application/vnd.ms-powerpoint)
2012-07-10 03:23 UTC, Jianyuan Li
no flags Details
Another UT file for this issue (27.50 KB, application/vnd.ms-powerpoint)
2012-07-10 03:24 UTC, Jianyuan Li
no flags Details
Patch for this issue (2.27 KB, patch)
2012-07-10 06:15 UTC, Jianyuan Li
awf.aoo: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-07 08:43:06 UTC
Created attachment 78120 [details]
sample file

build:
AOO3.4 r1327774

steps:
1. Launch AOO, open the attached .ppt.
2. Save the file as *.ppt
3. Reopen the saved ppt file in MS 2003 Powerpoint.

Defects:
all drawing objects lost

Notes: If reopen the saved ppt file with AOO, this problem does not exist
Comment 1 Jianyuan Li 2012-07-09 02:19:20 UTC
I am investigating this issue.
Comment 2 Jianyuan Li 2012-07-10 03:21:21 UTC
Root cause:
When import, incorrect resolving for custom shape "pSegmentInfo" causes incorrect "command" and "count" is set into document model. When export, incorrect content from import is exported. For example, there is a pSegmentInfo with value "0xB000". According to the incorrect logic, path escape command will be resolved as "msopathEscapeExtension(0x00)". But actually it is "msopathEscapeSmoothLine(0x10)".
Solution:
Resolve the pSegmentInfo according to specification[MS-ODRAW].pdf. See the detail analysis for pSegmentInfo in attachment "root cause.odt".
Comment 3 Jianyuan Li 2012-07-10 03:22:27 UTC
Created attachment 78604 [details]
root cause analysis for this issue
Comment 4 Jianyuan Li 2012-07-10 03:23:33 UTC
Created attachment 78605 [details]
UT file for this issue
Comment 5 Jianyuan Li 2012-07-10 03:24:08 UTC
Created attachment 78606 [details]
Another UT file for this issue
Comment 6 Jianyuan Li 2012-07-10 06:15:37 UTC
Created attachment 78611 [details]
Patch for this issue
Comment 7 SVN Robot 2012-07-10 11:01:06 UTC
"af" committed SVN revision 1359598:
#i119872# Fixed import of custom shapes from PPT.
Comment 8 Andre 2012-07-10 11:01:28 UTC
Comment on attachment 78611 [details]
Patch for this issue

Reviewed and tested: OK
Comment 9 Andre 2012-07-10 11:04:10 UTC
Setting status to fixed.
Comment 10 Jianyuan Li 2012-07-10 11:09:46 UTC
Thanks Andre.
Comment 11 louqle 2012-08-20 03:20:33 UTC
verified on XP SP3 and Ubuntu 12.04 against trunk build 1374181
Comment 12 louqle 2012-08-23 00:58:21 UTC
verified in xp, Ubuntu, win7,mac,win7-64,Vista,suse,redhat, SLED 11 SP1 64 bit, all pass. Close this bug.
Comment 13 Jianyuan Li 2012-08-23 02:49:09 UTC
*** Issue 119879 has been marked as a duplicate of this issue. ***
Comment 14 Jianyuan Li 2012-08-24 09:23:09 UTC
*** Issue 119778 has been marked as a duplicate of this issue. ***
Comment 15 Shenfeng Liu 2012-10-02 09:51:58 UTC
Set Target Milestone to AOO 3.5.0 for PM purpose.