Issue 119870 - [From Symphony]Line transparency value is lost after saving as another ppt by AOO
[From Symphony]Line transparency value is lost after saving as another ppt by...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: editing
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: jsc
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 08:35 UTC by Li Feng Wang
Modified: 2012-12-26 08:06 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (22.00 KB, application/vnd.ms-powerpoint)
2012-06-07 08:35 UTC, Li Feng Wang
no flags Details
samplefortestlinetransparency (119.50 KB, application/vnd.ms-powerpoint)
2012-06-08 09:56 UTC, Lei Debin
no flags Details
patch for ppt line color transparency export lost issue (705 bytes, patch)
2012-06-08 09:59 UTC, Lei Debin
debin.lei: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-07 08:35:49 UTC
Created attachment 78117 [details]
sample file

build:
AOO3.4 1

steps:
1. Launch AOO, open the attached .ppt.
2. Save the file as *.ppt
3. Reopen the saved ppt file.
4. Check "Line Transparency" value. 

Defect:  "Line Transparency" value is changed from 80% to 0%.
Comment 1 Lei Debin 2012-06-08 05:00:23 UTC
I am looking at the issue
Comment 2 Lei Debin 2012-06-08 07:58:31 UTC
The root cause found:
The linetransparency attribute is not exported at all.
The attribute can be exported in function
void EscherPropertyContainer::CreateLineProperties
Here is the export code for ppt
---------------------------------------------------------------
if ( EscherPropertyValueHelper::GetPropertyValue(
		aAny, rXPropSet, String( RTL_CONSTASCII_USTRINGPARAM( "LineTransparence" ) ), sal_True ) 
    )
{	
    sal_Int16 nTransparency = 0;
    if ( aAny >>= nTransparency )
    AddOpt( ESCHER_Prop_lineOpacity, ( ( 100 - nTransparency ) << 16 ) / 100 );		
}
----------------------------------------------------------------
Comment 3 Lei Debin 2012-06-08 09:56:07 UTC
Created attachment 78205 [details]
samplefortestlinetransparency

The sample created by me to test the line transparency.
There are three lines with different color transparency values (0,100 50).
Comment 4 Lei Debin 2012-06-08 09:59:08 UTC
Created attachment 78206 [details]
patch for ppt line color transparency export lost issue

I have tested with sample files for export ppt and odp.
Opened again with AOO and MS Power point no issue found
Comment 5 jsc 2012-06-08 16:09:00 UTC
reviewed, built and tested, patch applied

trunk -> 0
Comment 6 liuping 2012-06-21 07:24:53 UTC
in MS2010 ,confirm fixing defect ,pass