Issue 119866 - [From Symphony]The bullet in outline area lost after openning by AOO
[From Symphony]The bullet in outline area lost after openning by AOO
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: formatting
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 08:20 UTC by Li Feng Wang
Modified: 2012-12-26 08:04 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (101.00 KB, application/vnd.ms-powerpoint)
2012-06-07 08:20 UTC, Li Feng Wang
no flags Details
ut file (32.50 KB, application/vnd.ms-powerpoint)
2012-08-02 08:21 UTC, SunYing
no flags Details
patch for import placeholder with custom attr (2.21 KB, patch)
2012-08-02 08:22 UTC, SunYing
sunyingshadesun: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-07 08:20:11 UTC
Created attachment 78114 [details]
sample file

build:
AOO3.4 r1327774

steps:
1. Launch AOO and open the sample file;
2. Compare content with that openning by MS Office 
               		 
Actual Result: The bullete in outline area lose.

Expect Result: The new document's content is same as the original document.
Comment 1 SunYing 2012-08-01 09:42:17 UTC
root cause:
the place holder with custom attribute import error.
Comment 2 SunYing 2012-08-02 08:21:04 UTC
solution:
when the place holder with custom attribute, SdPage need to renew a placeholder.
Comment 3 SunYing 2012-08-02 08:21:54 UTC
Created attachment 78823 [details]
ut file
Comment 4 SunYing 2012-08-02 08:22:39 UTC
Created attachment 78824 [details]
patch for import placeholder with custom attr
Comment 5 Jianyuan Li 2012-08-14 08:41:33 UTC
Reviewed and looks good.
Comment 6 SVN Robot 2012-08-17 08:56:41 UTC
"sunying" committed SVN revision 1374179 into trunk:
#119866# fix the bullet in default outline area lost when open .ppt fileRepor...
Comment 7 sunying 2012-08-20 02:03:00 UTC
has been fixed
Comment 8 louqle 2012-08-24 04:30:36 UTC
verified on Ubuntu 12.04, XP SP3, Vista, Win7, Win7 64-bit, Suse 11 SP1, Redhat 6.1, Mac 10.7 against build 1376366,

SLED 11 SP1 64 bit against build 1376353

Pass. Close this bug