Issue 119860 - [From Symphony]The position of conncector change after save to another ppt by AOO
[From Symphony]The position of conncector change after save to another ppt by...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: formatting
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 07:58 UTC by Li Feng Wang
Modified: 2012-12-26 08:02 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (63.00 KB, application/vnd.ms-powerpoint)
2012-06-07 07:58 UTC, Li Feng Wang
no flags Details
another sample file with connector (102.00 KB, application/vnd.ms-powerpoint)
2012-06-07 09:51 UTC, Li Feng Wang
no flags Details
solution detail (234.54 KB, application/pdf)
2012-09-21 09:25 UTC, sunying
no flags Details
UT (61.50 KB, application/vnd.ms-powerpoint)
2012-09-21 09:26 UTC, sunying
no flags Details
patch for export bentconnector (7.33 KB, patch)
2012-09-21 09:28 UTC, sunying
sunying: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-07 07:58:14 UTC
Created attachment 78110 [details]
sample file

build:
AOO3.4 r1327774

steps:
1. Launch AOO and open the sample file;
2. Click "File->Save as" to export a new .ppt.
3. Close and reopen the new .ppt document with AOO.
4. Compare content with that in original document. 
               	
Actual Result: The position of connect change.

Expect Result: The new document's content is same as the one in Microsoft
Comment 1 Li Feng Wang 2012-06-07 09:51:28 UTC
Created attachment 78140 [details]
another sample file with connector
Comment 2 Li Feng Wang 2012-06-07 09:51:53 UTC
may have relation with Bug 119459
Comment 3 sunying 2012-09-13 03:15:11 UTC
The root cause is same with 119531.

*** This issue has been marked as a duplicate of issue 119531 ***
Comment 4 sunying 2012-09-19 02:21:25 UTC
reopen this issue.
Comment 5 sunying 2012-09-21 08:54:24 UTC
root cause:
 bentconnctor's attribute have not been exported correctly.
Comment 6 sunying 2012-09-21 09:25:31 UTC
Created attachment 79608 [details]
solution detail
Comment 7 sunying 2012-09-21 09:26:11 UTC
Created attachment 79609 [details]
UT
Comment 8 sunying 2012-09-21 09:28:34 UTC
Created attachment 79610 [details]
patch for export bentconnector

Solution
AOO use polygon[] to describe the bent connector.MS use angle, flip, adjust value and connector type to describe the bent connector. So It is necessary to calculate the above four factor by polygon[].Convert in function EscherPropertyContainer::CreateConnectorProperties() in file “\main\filter\source\msfilter\escherex.cxx”.
convert detail refer the attachment "solution.pdf"
Comment 9 Jianyuan Li 2012-09-25 02:24:11 UTC
patch looks good, reviewed.
Comment 10 sunying 2012-09-29 05:44:39 UTC
#119860# fix bent connector's type lost when save .ppt file
Reported by: Li Feng Wang
Patch by: Ying Sun
Review by: Jian Yuan Li
revision: 1391754
Comment 11 Li Feng Wang 2012-10-16 02:34:19 UTC
Verified pass on windows and linux with build r1397404