Issue 119831 - [From Symphony]Froze when saving the doc file to another one.
[From Symphony]Froze when saving the doc file to another one.
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: save-export
3.4.0
PC All
: P3 critical (vote)
: 4.0.0
Assigned To: jsc
:
Depends on:
Blocks: 120823
  Show dependency treegraph
 
Reported: 2012-06-06 06:40 UTC by Li Lin Yi
Modified: 2012-10-18 06:09 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
FFC252FFCSW_Table_GroupedObject0010.doc (110.00 KB, application/msword)
2012-06-06 06:40 UTC, Li Lin Yi
no flags Details
simplified bug doc to reproduce the issue (7.71 KB, application/vnd.oasis.opendocument.text)
2012-09-17 13:35 UTC, jsc
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Li Lin Yi 2012-06-06 06:40:23 UTC
Created attachment 78058 [details]
FFC252FFCSW_Table_GroupedObject0010.doc

Steps to Reproduce:
1. Open the attache doc file.
2. Save it to another doc file.

Expected Results:
File can be saved correctly.

Actual Results: 
Froze while saving as doc.
It can be saved as odt.

Build Date & Platform:
Build revision is Rev. 1327774.
Comment 1 jsc 2012-09-17 07:29:19 UTC
First evaluation shows that the problem is related to the contained bookmarks.
Comment 2 jsc 2012-09-17 13:35:38 UTC
Created attachment 79537 [details]
simplified bug doc to reproduce the issue
Comment 3 jsc 2012-09-17 13:37:41 UTC
The issue can be reproduced with a simplified bug doc. Simply try to save the attached simplified bug doc to MS word 97/200/XP (.doc).

The problem is identified and the fix is under investigation and testing.
Comment 4 jsc 2012-09-17 13:39:19 UTC
Oliver gave me some fast and quick introduction in the related writer code after I figured out that the problem is related to the bookmarks.
Comment 5 SVN Robot 2012-09-18 15:35:07 UTC
"jsc" committed SVN revision 1387217 into trunk:
#119831# check again the node if the bookmark belongs to it (start and end po...
Comment 6 jsc 2012-09-18 15:40:13 UTC
The problem is that the bookmarks overlap 2 paragraphs. And the internal check if the bookmark belongs to the node have to be repeated for both the start and end position. Otherwise it's possible that a bookmark gets detected to belong to a node but isn't. In this case the loop condition is never reached and we are looping...
Comment 7 Du Jing 2012-10-08 09:10:57 UTC
verified on the build AOO3.5_r1391367
Comment 8 Shenfeng Liu 2012-10-18 06:09:34 UTC
Update Target Milestone to AOO 3.5.0.