Issue 119740 - [From Symphony]animation flash once doesn't work after save the ppt by aoo
[From Symphony]animation flash once doesn't work after save the ppt by aoo
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
: 119699 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 01:58 UTC by louqle
Modified: 2012-12-26 08:57 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (136.50 KB, application/vnd.ms-powerpoint)
2012-06-05 01:58 UTC, louqle
no flags Details
119740 & 119699 patch (1.05 KB, patch)
2012-06-21 08:40 UTC, Tang Meng
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description louqle 2012-06-05 01:58:00 UTC
Created attachment 77948 [details]
sample file

1. open the attached ppt file by aoo
2. save as another .ppt file
3. reopen the new .ppt file by aoo or powerpoint 2003, play

the animation flash once doesn't work
Comment 1 Tang Meng 2012-06-21 08:02:04 UTC
I am looking at this bug.
Comment 2 Tang Meng 2012-06-21 08:40:19 UTC
Created attachment 78422 [details]
119740 & 119699 patch
Comment 3 Tang Meng 2012-06-21 08:43:00 UTC
When save to PPT. the fill properties for TRANSITIONFILTER and ANIMATE note should use default value, if they parent node is default value.
Comment 4 Andre 2012-06-21 13:08:15 UTC
@Tang Meng: Can you explain why the patch is necessary?  There is already code in GetFillMode(...) that returns nFill when nFill==AnimationFill::DEFAULT.

A general explanation of the root cause and the idea of the fix would be helpful also.
Comment 5 WangZhe 2012-06-25 06:14:40 UTC
*** Issue 119699 has been marked as a duplicate of this issue. ***
Comment 6 Tang Meng 2012-06-25 07:15:36 UTC
     When save to PPT. the fill properties for TRANSITIONFILTER and ANIMATE note should use default value. This is 'AnimationFill::DEFAULT'. In the old code when 'nFill == AnimationFill::DEFAULT', the nFill is set as 'nFillDefault'. But 'nFillDefault' isn't 'AnimationFill::DEFAULT' in some case. The result is that we don't return 'AnimationFill::DEFAULT'. So the patch is necessary.
Comment 7 Andre 2012-06-25 08:44:27 UTC
Thanks for the explanation.  It would be nice to have that as comment in the patch instead of listing the bugs it fixes--after the patch is applied the bugs are gone and a description of old bugs is not so interesting.
Comment 8 Andre 2012-06-25 09:10:05 UTC
Reviewed.  Committed with SVN revision 1353438.
Comment 9 Li Feng Wang 2012-08-20 05:41:11 UTC
Verified pass on Windows XP, Redhat 32bit, Mac with AOO trunk r1374181