Issue 119714 - AOO3.4 crash when open the sample file.
AOO3.4 crash when open the sample file.
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: open-import
3.4.0
All All
: P3 critical (vote)
: 4.0.0
Assigned To: hdu@apache.org
:
Depends on:
Blocks: 120823
  Show dependency treegraph
 
Reported: 2012-06-04 08:03 UTC by Du Jing
Modified: 2013-07-11 13:27 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (14.30 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-06-04 08:03 UTC, Du Jing
no flags Details
crash stack for AOO 3.4.1 on OSX (3.33 KB, text/plain)
2012-08-28 12:44 UTC, hdu@apache.org
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2012-06-04 08:03:19 UTC
Created attachment 77925 [details]
sample file

build info:AOO3.4_1327774

Steps:
1.open the sample file in AOO3.4

defect:
AOO3.4 crash

Note:
when open the sample by AOO3.4 in windows,no crash,but some content in the sample lost.
Comment 1 bjcheny 2012-06-12 02:50:26 UTC
I can't reproduce it on r1344574.
@bjdujing
It may be fixed indirectly. Please help confirm.
Comment 2 Terry Yang 2012-06-12 08:37:45 UTC
Can repro on rev.1325589, now there is no offical release for rev.1344574, so we can't verify it on rev.1344574.
Comment 3 hdu@apache.org 2012-08-28 12:44:47 UTC
Created attachment 79201 [details]
crash stack for AOO 3.4.1 on OSX

The crash is reproducible with AOO 3.4.1 on Mac OSX.
Comment 4 bjcheny 2012-09-06 03:05:25 UTC
I am working on it.
Comment 5 SVN Robot 2012-09-06 11:56:39 UTC
"hdu" committed SVN revision 1381567 into trunk:
#i119714# prevent crash in SwXTextSection::attach()As SwDoc::InsertSwSection(...
Comment 6 hdu@apache.org 2012-09-06 12:08:09 UTC
At least on MacOSX the crash was reproducible on yesterday's trunk and on AOO 3.4.1 and is fixed with the commit above.
Comment 7 binguo 2012-11-14 08:41:19 UTC
Verified on Aoo_Trunk_20121109.1800 rev 1407366
No Crash. this bug is fixed.
Comment 8 binguo 2012-11-14 08:44:25 UTC
close it.