Issue 119711 - [From Symphony]exit animation changed after save as ppt file to another ppt
[From Symphony]exit animation changed after save as ppt file to another ppt
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: editing
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
: 120696 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 07:58 UTC by Li Feng Wang
Modified: 2012-10-02 09:57 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file with exit animation (144.50 KB, application/vnd.ms-powerpoint)
2012-06-04 07:58 UTC, Li Feng Wang
no flags Details
patch for export animation delay (505 bytes, patch)
2012-09-07 02:25 UTC, sunying
sunying: review?
Details | Diff
UT file (59.00 KB, application/vnd.ms-powerpoint)
2012-09-07 02:47 UTC, sunying
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-04 07:58:03 UTC
Created attachment 77922 [details]
sample file with exit animation

build:
AOO3.4 r1327774

steps:
1)open sample ppt file
2)press F5 to play screen show
2)save as to another ppt file
3)play saved ppt file and compare it with step2

defect:
exit with direction animation became exit disappear.

have no problem when saving ppt file to odp
Comment 1 sunying 2012-08-22 01:28:23 UTC
I'm checking this defect.
Comment 2 sunying 2012-08-24 06:04:25 UTC
root cause:
  When saving the "Delay" value, the AnimationExporter::exportAnimEvent function use an uninitalized value eTiming.
 at line 1381 in file "\main\sd\source\filter\eppt\pptexanimations.cxx",the "if ( eTiming == Timing_INDEFINITE )" is always false, and the nBegin value never is assigned by fTiming. so the "Delay" value always is zero.
   
solution:
 according in "\main\offapi\com\sun\star\animationstiming.idl", describe the indefinite of Timing:
 enum Timing
{
	/** specifies that a duration, end or start time is indefinite*/
	INDEFINITE,

	/** specifies a simple duration as the intrinsic media duration.
		This is only valid for elements that define media.
	*/
	MEDIA
};
only and if only the eTiming is Timing_INDEFINITE, the animation has a fTiming, so the judgment "if ( eTiming == Timing_INDEFINITE )" is unnecessary.
Comment 3 sunying 2012-09-07 02:25:43 UTC
Created attachment 79327 [details]
patch for export animation delay
Comment 4 sunying 2012-09-07 02:47:56 UTC
Created attachment 79330 [details]
UT file
Comment 5 WangZhe 2012-09-07 06:07:58 UTC
*** Issue 120696 has been marked as a duplicate of this issue. ***
Comment 6 Jianyuan Li 2012-09-10 01:56:02 UTC
Reviewed and tested. OK. Remove the unnecessary judgement.
Comment 7 SVN Robot 2012-09-10 02:29:32 UTC
"sunying" committed SVN revision 1382623 into trunk:
#119711# support the delay var when export ppt file by AOOReported by: Wang L...
Comment 8 sunying 2012-09-10 02:34:01 UTC
has been fixed
Comment 9 Li Feng Wang 2012-09-18 08:16:59 UTC
can't reproduce on trunk r1384699
Comment 10 Shenfeng Liu 2012-10-02 09:57:07 UTC
Set Target Milestone to AOO 3.5.0 for PM purpose.