Issue 119649 - [From Symphony]Hyperlink font size increased if saved to .doc file
[From Symphony]Hyperlink font size increased if saved to .doc file
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: Chen Peng
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 01:55 UTC by Yan Ji
Modified: 2012-10-09 09:41 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (27.50 KB, application/msword)
2012-06-01 01:55 UTC, Yan Ji
no flags Details
Patch for Bug 119649 (1.05 KB, patch)
2012-08-07 06:13 UTC, Chen Peng
chenpeng2006: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-06-01 01:55:39 UTC
Created attachment 77872 [details]
sample

Build: AOO3.4
Steps:
1. Open sample file
2. Save it to .doc file
3. Reload saved doc file

Defect: Hyerlink font size increased
Comment 1 Chen Peng 2012-08-07 06:11:37 UTC
1. Root Cause:
In the id definition, RES_TXTATR_INETFMT must precede RES_TXTATR_CHARFMT, so that link style can overwrite char style. And in #i24291# it describes "All we want to do is ensure for now is that if a charfmt exist in the character 
properties that it rises to the top and is exported first.", so hyperlink text property will override the original text property in this situation.

2. Resolution:
Ignore the link style in such situation when doing ms word filter.
Comment 2 Chen Peng 2012-08-07 06:13:14 UTC
Created attachment 78864 [details]
Patch for Bug 119649
Comment 3 Chen Peng 2012-08-07 06:16:38 UTC
2. Resolution:
Ignore the link style in such situation when doing ms word filter exports.


(In reply to comment #1)
> 1. Root Cause:
In the id definition, RES_TXTATR_INETFMT must precede
> RES_TXTATR_CHARFMT, so that link style can overwrite char style. And in
> #i24291# it describes "All we want to do is ensure for now is that if a
> charfmt exist in the character 
properties that it rises to the top and is
> exported first.", so hyperlink text property will override the original text
> property in this situation.

2. Resolution:
Ignore the link style in such
> situation when doing ms word filter export.
Comment 4 Jian Hong Cheng 2012-08-22 05:19:42 UTC
Committed by revision 1375901..thanks for the patch.
Comment 5 Du Jing 2012-08-28 03:05:57 UTC
verified on the build r1377620
Comment 6 Shenfeng Liu 2012-10-09 09:41:22 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.