Issue 119632 - [From Symphony]Macro button lost if save template to .doc file
[From Symphony]Macro button lost if save template to .doc file
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 08:26 UTC by Yan Ji
Modified: 2012-12-26 08:34 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (65.97 KB, application/msword)
2012-05-31 08:26 UTC, Yan Ji
no flags Details
patch for the issue (721 bytes, patch)
2012-06-14 05:54 UTC, Lei Debin
debin.lei: review? (zjchencdl)
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-05-31 08:26:33 UTC
Created attachment 77856 [details]
sample

Build: AOO 3.4
Steps:
1. Open attached template file
2. Save it as .doc file
3. Reopen it.

Defect: The macro button lost
Comment 1 Lei Debin 2012-06-14 02:38:58 UTC
I am working on it
Comment 2 Lei Debin 2012-06-14 05:51:46 UTC
The root cause for the issue is the MACROBUTTON field is not exported at all.
There is a function named as  
void AttributeOutputBase::TextField( const SwFmtFld& rField ) for export field, located in main\sw\source\filter\ww8\ww8atr.cxx
Need add some codes here to output the MACROBUTTON field.
Comment 3 Lei Debin 2012-06-14 05:54:39 UTC
Created attachment 78316 [details]
patch for the issue

Add export MACROBUTTON field codes in 
void AttributeOutputBase::TextField( const SwFmtFld& rField )
Comment 4 zjchen 2012-07-04 06:07:33 UTC
This patch is ok to me. Looking forward to see your solution update in AOO repository.
Comment 5 Lei Debin 2012-07-04 06:36:34 UTC
Zuo Jun, thanks for your review.
Now, the code check into the trunk at revision: 1357104
Comment 6 Lei Debin 2012-07-04 06:38:03 UTC
fixed , pls help to verify it, thx.
Comment 7 Du Jing 2012-08-21 05:17:20 UTC
when reopen the saved doc document,the macro button is not same with in orininal document
Comment 8 Du Jing 2012-08-28 03:09:00 UTC
verified on the build 1377620