Issue 119631 - [From Symphony]Teardrop shape can not show correct in pptx sample file
[From Symphony]Teardrop shape can not show correct in pptx sample file
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: viewing
OOo 3.4 Beta
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: WangZhe
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 08:26 UTC by zongdj
Modified: 2012-10-18 06:39 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
shape sample (38.52 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2012-05-31 08:26 UTC, zongdj
no flags Details
Fix patch for this issue (7.42 KB, patch)
2012-09-06 08:14 UTC, Ma Bingbing
jiazema: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description zongdj 2012-05-31 08:26:25 UTC
Created attachment 77855 [details]
shape sample

Build:
Aoo3.4

Steps:
1.Open the attached sample file in Aoo3.4
2.Check the Teardrop in slide 1

Bug:
It show as ellipes.
Comment 1 Du Jing 2012-07-17 06:11:44 UTC
confirmed,change its status
Comment 2 Ma Bingbing 2012-08-31 06:21:29 UTC
root cause:
     Aoo don't support teardrop now, and use ellipse to instead when import from pptx
Comment 3 Ma Bingbing 2012-09-04 08:09:10 UTC
Solution: 
  1. add the necessary information for "teardrop" which includes "path, adjust value, handle... " in file EnhancedCustomShapeGeometry.cxx and the corresponding definition and declaration.

  2. when save the 'teardrop' to ppt, because it isn't the default object of ppt but pptx, so IsDefaultObject(line 2354)will return false.
Comment 4 Ma Bingbing 2012-09-06 08:14:00 UTC
Created attachment 79312 [details]
Fix patch for this issue
Comment 5 Ma Bingbing 2012-09-06 08:24:57 UTC
There are some strange behaviors : when AOO create one some custom shape and save it to PPT, the position of adjust value would be different in AOO. What's more, open the ppt file with PPTX, the position of adjust value be changed too(ex. moon).

Another question is that, after saving the sample file to PPT with AOO, the adjust value is correct. But, open the saved ppt file with pptx, the adjust value is lost.
Comment 6 WangZhe 2012-09-07 03:34:19 UTC
I'll take this one
Comment 7 WangZhe 2012-09-07 05:07:38 UTC
Deliver At revision: 1381871
Comment 8 liuping 2012-09-18 08:46:24 UTC
verify on AOO3.5_r1386711 on winxp/Win7-64bit/SLED 11 SP1 32 bit/Mac 10.7/Ubuntu 10.04 32 bit ,pass
Comment 9 Shenfeng Liu 2012-10-18 06:39:34 UTC
Update Target Milestone to AOO 3.5.0.