Issue 119629 - [From Symphony]Bullet color is lost when open pptx sample file
[From Symphony]Bullet color is lost when open pptx sample file
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: formatting
OOo 3.4 Beta
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: jsc
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 08:09 UTC by zongdj
Modified: 2012-10-09 05:30 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
bullet color (269.54 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2012-05-31 08:09 UTC, zongdj
no flags Details
patch for bullet color (2.32 KB, patch)
2012-06-05 07:10 UTC, bjcheny
no flags Details | Diff
patch for bullet color in pptx (2.34 KB, patch)
2012-06-08 05:25 UTC, bjcheny
companycy: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description zongdj 2012-05-31 08:09:43 UTC
Created attachment 77852 [details]
bullet color

Build:
Aoo3.4

Steps:
1.Open the attached sample file in Aoo3.4
2.Check the bullet color 

Bug:
The bullet color change to black, it should same with the text color
Comment 1 bjcheny 2012-06-04 09:42:34 UTC
1. Root cause:
Bullet color isn't set with correctly.
There are many options for setting color for bullet. 
However, there is priority.
2. Resolution:
Figure out which color to apply on bullet color.

Will send out patch for review soon.
Comment 2 bjcheny 2012-06-05 06:49:05 UTC
1. Root cause:
The bullet color inherits from closest text in this sample.

2. Resolution:
Apply text's color to bullet color.

3. Test: pass on Xp
Comment 3 bjcheny 2012-06-05 07:10:09 UTC
Created attachment 77992 [details]
patch for bullet color
Comment 4 bjcheny 2012-06-08 05:25:40 UTC
Created attachment 78174 [details]
patch for bullet color in pptx

In this sample, the color is from bullet's closest text.
Thus add code to get color from closest text and apply it to bullet color.
It involves
1. add lcl_getBulletclr() to get color from text from runs and apply it to bullet color
2. add a const member function getBulletList() to be invoked in TextParagraph::insertAt() const
Comment 5 jsc 2012-06-08 11:31:58 UTC
reviewed, built and tested, patch applied on trunk

trunk -> revision 1348027
Comment 6 liuping 2012-06-25 02:54:13 UTC
confirm fixing the bug on ver 1351249 in Win7 ,pass
Comment 7 Shenfeng Liu 2012-10-09 05:30:04 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.