Issue 119628 - [From Symphony]Arrow shape changed is save doc file by AOO
[From Symphony]Arrow shape changed is save doc file by AOO
Status: VERIFIED FIXED
Product: Writer
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 08:09 UTC by Yan Ji
Modified: 2012-10-18 06:19 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (23.50 KB, application/octet-stream)
2012-05-31 08:09 UTC, Yan Ji
no flags Details
snapshot (14.35 KB, image/png)
2012-05-31 08:13 UTC, Yan Ji
no flags Details
Patch for this issue (1.05 KB, patch)
2012-08-31 03:14 UTC, Jianyuan Li
lijianyuan1983: review?
Details | Diff
UT file for this issue (26.00 KB, application/msword)
2012-08-31 03:15 UTC, Jianyuan Li
no flags Details
UT file for this issue (22.00 KB, application/msword)
2012-08-31 03:16 UTC, Jianyuan Li
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-05-31 08:09:00 UTC
Created attachment 77851 [details]
sample

Build: AOO3.4
Steps:
1. Open attachment in AOO 3.4
2. Save it as another .doc file
3. Reload new saved file

Defect: Arrow changed
Comment 1 Yan Ji 2012-05-31 08:13:36 UTC
Created attachment 77853 [details]
snapshot
Comment 2 Jianyuan Li 2012-08-30 08:27:59 UTC
I am investigating this issue. The export issue has been fixed by the fix for bug 119495. Here will focus on the oval arrow end which becomes smaller than origin when import.
Comment 3 Jianyuan Li 2012-08-31 03:08:42 UTC
Root cause: For arrow in presentation, no this issue. Because the basic unit for arrow width is not consistent in Document(twip) and Presentation(100mm). And there is a critical value 2pt(70 100mm, 40 twip) which is used incorrectly for document.
Resolution: Use the critical value as 40 other than 70 for Document arrow width.
Notes: There is a fix for bug 33630. The fix can fix the sample arrow(line width is less than 2pt). But a regression is cause by it. For line width larger than 2pt, they will imported incorrectly(become smaller than MS).
Comment 4 Jianyuan Li 2012-08-31 03:14:58 UTC
Created attachment 79248 [details]
Patch for this issue
Comment 5 Jianyuan Li 2012-08-31 03:15:36 UTC
Created attachment 79249 [details]
UT file for this issue
Comment 6 Jianyuan Li 2012-08-31 03:16:00 UTC
Created attachment 79250 [details]
UT file for this issue
Comment 7 sunying 2012-09-10 02:31:03 UTC
patch looks good, reviewed and tested.
Comment 8 SVN Robot 2012-09-10 08:17:01 UTC
"lijiany" committed SVN revision 1382686 into trunk:
#119628# Arrow shape changed is save doc file by AOOReported by: Yan JiReview...
Comment 9 Jianyuan Li 2012-09-10 09:16:38 UTC
Issue is fixed
Comment 10 Du Jing 2012-10-08 06:34:04 UTC
verified on the build AOO3.5_r1387482
Comment 11 Shenfeng Liu 2012-10-18 06:19:01 UTC
Update Target Milestone to AOO 3.5.0.