Issue 119609 - [From Symphony]Alphabetical and roman numberals became ditial numbering
[From Symphony]Alphabetical and roman numberals became ditial numbering
Status: VERIFIED FIXED
Product: Writer
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 02:22 UTC by Yan Ji
Modified: 2012-12-26 08:47 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (31.00 KB, application/msword)
2012-05-31 02:22 UTC, Yan Ji
no flags Details
snapshot (70.83 KB, image/png)
2012-05-31 02:30 UTC, Yan Ji
no flags Details
patch for bug 119609 (704 bytes, patch)
2012-07-08 13:15 UTC, zjchen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-05-31 02:22:19 UTC
Created attachment 77827 [details]
sample

Build AOO3.4
Load sample file in AOO and compare with MS Office

Defect: The alphabetical and roman numberals became digitial numbering
Comment 1 Yan Ji 2012-05-31 02:30:10 UTC
Created attachment 77828 [details]
snapshot
Comment 2 zjchen 2012-07-08 13:14:18 UTC
Toggle the filed code in sample file, there is a switch "\*MERGEFORMAT" behind the numbering.
The problem is that field code parser will parse the switch after it return correct numbering format,and then replace the correct value with a default digital numbering format since the switch code cannot be mapped to one of numbering format in svx.
Notice there are two switcher  "\*MERGEFORMAT" and "\*CHARFORMAT", so the solution is that skip over MERGEFORMAT and CHARFORMAT when field code parser parse numbering.
Comment 3 zjchen 2012-07-08 13:15:42 UTC
Created attachment 78591 [details]
patch for bug 119609
Comment 4 SVN Robot 2012-07-19 02:16:31 UTC
"leidb" committed SVN revision 1363207 into trunk:
#119609# Fixed alphabetical and roman numberals became ditial numbering Repor...
Comment 5 Lei Debin 2012-07-19 02:19:12 UTC
Good work, Zuo Jun, thx. Committed at revision: 1363207
Comment 6 Lei Debin 2012-08-21 03:13:04 UTC
fixed
Comment 7 Du Jing 2012-08-21 03:31:18 UTC
verified on the AOO3.5_r1374181