Issue 119587 - [From Symphony]MS Word that has Table that with Text wrap around the table can not be shown correctly
[From Symphony]MS Word that has Table that with Text wrap around the table ca...
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 08:32 UTC by Yan Ji
Modified: 2012-10-18 05:49 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (27.50 KB, application/msword)
2012-08-27 01:52 UTC, Lei Debin
no flags Details
patch for the issue (3.77 KB, patch)
2012-08-28 01:00 UTC, Lei Debin
no flags Details | Diff
patch for the issue (4.28 KB, patch)
2012-10-09 03:10 UTC, Lei Debin
debin.lei: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-05-30 08:32:03 UTC
Build: AOO3.4
The attached document does not open correctly in AOO

More information:
There are table property with Text Wrap around the table. Since the table is too long. When convert it into AOO,the table is embedded in a Frame. The frame can not cross the page. So the table can not be shown totally.
Comment 1 Lei Debin 2012-08-27 01:52:31 UTC
Created attachment 79153 [details]
sample file

This is a sample file to reproduce the issue.
There is a table cross 2 pages with wrap attribution is Around.
AOO will combine the 2 pages with one.
The expected result will show as MS one.
Comment 2 Lei Debin 2012-08-27 02:03:07 UTC
I find the root cause:
If table content overload one page and with the wrap:Around, table content postion may be show incorrectly.
Comment 3 Lei Debin 2012-08-28 00:59:41 UTC
The solution will be, if no text content before wrapping around table, ignored "Around" property. Then table content will show correct.
Comment 4 Lei Debin 2012-08-28 01:00:35 UTC
Created attachment 79179 [details]
patch for the issue
Comment 5 zjchen 2012-08-29 02:46:09 UTC
I am volunteering to review this patch.

The sample file is a special case, and the patch is fixed this problem via ignore ignored "Around" property. 

I suggest still import the table wrapping property because it is an essential attribute for table and we'd better change the table display mechanism in SW core function from my point of view.
Comment 6 zjchen 2012-08-29 03:08:09 UTC
Sorry for my mistake, my Comment 5 is just personal opinion for this issue, NOT a 

review attitude.

hope that someone familiar with the core function provide further comments and 

review this patch
Comment 7 Lei Debin 2012-10-09 03:10:58 UTC
Created attachment 79749 [details]
patch for the issue
Comment 8 SVN Robot 2012-10-09 03:26:33 UTC
"zjchen" committed SVN 0 into trunk:
#i119587#  For doc file loaded by AOO, correct table position when table acro...
Comment 9 zjchen 2012-10-09 03:33:39 UTC
mark as resolved
Comment 10 Du Jing 2012-10-16 02:58:59 UTC
verified on the build AOO3.5_r1397404
Comment 11 Shenfeng Liu 2012-10-18 05:49:26 UTC
Update Target Milestone to AOO 3.5.0.