Issue 119581 - [From Symphony] MS's Macro button symbol can't correct display in aoo 3.4
[From Symphony] MS's Macro button symbol can't correct display in aoo 3.4
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
: 119438 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 07:29 UTC by louqle
Modified: 2012-12-26 08:31 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample files and snapshots (207.20 KB, application/x-zip-compressed)
2012-05-30 07:29 UTC, louqle
no flags Details
patch for the issue (2.69 KB, patch)
2012-07-19 07:19 UTC, Lei Debin
debin.lei: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description louqle 2012-05-30 07:29:54 UTC
Created attachment 77798 [details]
sample files and snapshots

open two attachment files, The Mail icon button and Check box button can not correct display
Comment 1 Lei Debin 2012-07-09 07:58:05 UTC
I am fixing it.
Comment 2 Lei Debin 2012-07-16 05:28:23 UTC
The special "macro button" is some symbol in Winding font. MS Word mixes these 
characters in field code directly, and SW fails to parse them. Normally these character without any property specification mixed in other font characters can not be displayed. Seems there are tricks in MS Word. We may also map these character to the correct font.
Comment 3 Lei Debin 2012-07-19 07:17:41 UTC
solution is to find font code by font name-"Wingdings" and set to char.
Comment 4 Lei Debin 2012-07-19 07:19:06 UTC
Created attachment 78685 [details]
patch for the issue
Comment 5 Jianyuan Li 2012-07-20 01:38:59 UTC
Review and test. OK.
Comment 6 SVN Robot 2012-07-20 01:39:53 UTC
"leidb" committed SVN 0 into trunk:
#119581# fix import issue for 'checkin' 'checkout' 'showsample' macro button ...
Comment 7 Lei Debin 2012-07-20 01:40:58 UTC
Resolved.
Comment 8 SVN Robot 2012-07-20 01:57:59 UTC
"leidb" committed SVN 0 into trunk:
#119581# fix import issue for left and right horizontal alignment in text box...
Comment 9 Lei Debin 2012-07-20 02:02:20 UTC
(In reply to comment #8)
> "leidb" committed SVN 0 into trunk:
> #119581# fix import issue for left and right horizontal alignment in text
> box...

Sorry I input the wrong issue id, the msg should go to 119517, pls ignore it here :-(
Comment 10 Du Jing 2012-08-21 01:44:12 UTC
verified on the AOO3.5_r1374181
Comment 11 Lei Debin 2012-09-05 06:02:07 UTC
*** Issue 119438 has been marked as a duplicate of this issue. ***