Issue 119570 - [From Symphony]the content display mess when open the sample in AOO3.4
[From Symphony]the content display mess when open the sample in AOO3.4
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 06:37 UTC by Du Jing
Modified: 2012-12-26 08:21 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (117.00 KB, application/vnd.ms-powerpoint)
2012-05-30 06:37 UTC, Du Jing
no flags Details
The line result in this issue (116.23 KB, image/jpeg)
2012-08-02 02:00 UTC, Jianyuan Li
no flags Details
Patch for this issue (862 bytes, patch)
2012-08-02 02:01 UTC, Jianyuan Li
lijianyuan1983: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2012-05-30 06:37:23 UTC
Created attachment 77789 [details]
sample file

build info:AOO3.4_1327774

Steps:
1.open the sample in the AOO3.4
2.check the content display

defect:
the content in the slide content display mess,but in MS office,it display normally
Comment 1 MMellor 2012-06-16 22:19:12 UTC
I was able to replicate the problem; however, based on the Description field, I am unclear about the version of MS PowerPoint that was used and whether or not the document created in MS PowerPoint or Openoffice Presentations.

My System Information:
OpenOffice.org 3.4.0
AOO340m1 (Build:9590) - Rev 1325589
Windows 7 Home Premium
Acer Aspire 5517
AMD Athlon(tm) X2 Dual processor L310 1.2 GHz
64-bit Operating System

As I do not have MS PowerPoint loaded on my laptop I had to use Virtual Office to log onto another site and used MS PowerPoint 2007 to view the file.

Steps to Reproduce:
1) Downloaded the file that was attached to the Bugzilla ticket to my laptop.
2) Opened the file using OpenOffice Presentation 3.4.0

Result: Parts of the document appeared to be overlapping each other.  There also appeared to be some formatting missing:
・4 of the rectangles appeared correct but the 8 others appeared overlapped or missing
・3 of the vertical lines looked OK, whereas the other 2 were overlapped or missing
・Some of the text seemed to be wrapped into a very narrow column
・Most other text is misplaced
・All the blue lines between rectangles are missing

3) Uploaded the file to Dropbox
4) Logged on to Virtual Office
5) Open the file that I uploaded to Dropbox in MS PowerPoint 2007

Result: The file displayed properly with no overlapping and the formatting was in place.
Comment 2 Du Jing 2012-07-17 06:13:25 UTC
confirmed,change its status
Comment 3 Jianyuan Li 2012-07-31 05:35:41 UTC
I am working on this issue.
Comment 4 Jianyuan Li 2012-08-02 01:59:15 UTC
Root Cause:
The orgnization chart in sample file cause the issue. There is a so weird line in the chart. Please see attachment "weird line.jpg". First it is part of the chart. You cannot delete it except that the chart is deleted. Second, it will not be moved with the moving of the chart. For the line, it is part of the chart(a group). But it has an individual property like an independent shape out of the chart(group). This cause the chaos for chart(group) import.
Resolution:
When import group, just import rectangular once. Others will be taken as children of the rectangular anyway.
Comment 5 Jianyuan Li 2012-08-02 02:00:05 UTC
Created attachment 78811 [details]
The line result in this issue
Comment 6 Jianyuan Li 2012-08-02 02:01:36 UTC
Created attachment 78812 [details]
Patch for this issue
Comment 7 Jianyuan Li 2012-08-06 08:34:37 UTC
The connector is imported incorrectly in sample file. This issue has been resolved by issue 120437.
Comment 8 SunYing 2012-08-14 09:10:39 UTC
The patch looks good, reviewed.
Comment 9 SVN Robot 2012-08-16 02:19:48 UTC
"lijiany" committed SVN 0 into trunk:
#119570# fix chaos grouped object when importReported by: Du JingPatch by: Ji...
Comment 10 Jianyuan Li 2012-08-16 02:44:05 UTC
Fixed
Comment 11 liuping 2012-08-20 06:22:43 UTC
Verified pass on Windows7-64bit, Redhat 32bit,ubutu 10.04 Mac10.7 with AOO trunk 0