Issue 119559 - [From Symphony]Vertical letters in "VerticalText" fontwork get horizontal when opening .ppt file
[From Symphony]Vertical letters in "VerticalText" fontwork get horizontal whe...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: save-export
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 06:00 UTC by Li Feng Wang
Modified: 2012-12-26 08:06 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file with fontwork (25.50 KB, application/vnd.ms-powerpoint)
2012-05-30 06:00 UTC, Li Feng Wang
no flags Details
before save screenshot (14.66 KB, image/png)
2012-05-30 06:02 UTC, Li Feng Wang
no flags Details
after save screenshot (21.53 KB, image/png)
2012-05-30 06:03 UTC, Li Feng Wang
no flags Details
patch for the issue (873 bytes, patch)
2012-06-13 06:56 UTC, Lei Debin
no flags Details | Diff
Code fix patch (923 bytes, patch)
2012-06-13 08:24 UTC, WangZhe
hdu: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-05-30 06:00:04 UTC
Created attachment 77775 [details]
sample file with fontwork

build:
AOO3.4 r1327774

steps:
1. Launch AOo3.4
2. Open the attached .ppt file    
3. Save it to another .ppt file
4. Reopen it with both AOO3.4 and MS
5. Check the fontwork in slide 2.

Defect: 
See the attached snapshots, All Vertical letters in the fontwork change to horizontal after saved by AOO3.4.
Comment 1 Li Feng Wang 2012-05-30 06:02:36 UTC
Created attachment 77776 [details]
before save screenshot
Comment 2 Li Feng Wang 2012-05-30 06:03:15 UTC
Created attachment 77777 [details]
after save screenshot
Comment 3 Lei Debin 2012-06-13 02:21:30 UTC
I will check the issue
Comment 4 Lei Debin 2012-06-13 06:45:52 UTC
Root cause is 
The Fontwork object has no vertical properties. When read the text is rotated in PPT, we will set the vertical property to the paragraph in this object. And when export it to PPT file format, we didn't set this flag to the file again.
So reopen, this property is not set to this object
Here is the solution:
When export one fontwork object, check the outlinerparagraph. If it is vertical, set the 0x20000 flag to TextPathFlags.
Comment 5 Lei Debin 2012-06-13 06:56:42 UTC
Created attachment 78286 [details]
patch for the issue
Comment 6 WangZhe 2012-06-13 08:24:40 UTC
Created attachment 78288 [details]
Code fix patch
Comment 7 hdu@apache.org 2012-06-13 08:58:59 UTC
The two patches look almost identical except for formatting except for the use of the full path vs. the local path.
Comment 8 hdu@apache.org 2012-06-13 09:21:46 UTC
Thanks for the great analysis of the problem and the patch. Applied as rev 1349700.
Comment 9 liuping 2012-06-21 07:27:38 UTC
confirm fixing the bug on ver 1351249 in Win7 ,pass